Question New version of Freeview no EPG

Dansssssy

Novice Member
Hi folks. Got a hisense series 7 75m7000uwd. This one's got me, Freeview epg was working great, then Freeview epg upgraded itself. Now the Freeview epg doesn't work. The rest of Freeview works, catchup, mytv etc all fine. I get epg info in the " my tv" window, but when go to the Freeview epg, I get the channel list, but no programs at all. Tried googling the issue but can't find any help. Hoping someone here can help.

Thanks in advance.
Dan and Mary.
 

Gavtech

Administrator
Welcome to the forum.

Unpower the device for 5 minutes, then reconnect.
It may take a little while for the EPG to repopulate.
 

Dansssssy

Novice Member
Thanks for the help. Tried that already. Completely powered down, removed the power cable, left for half an hour still no epg. I'm surprised no one else has mentioned anything. It takes a minute before all the channels load, but when they do, they're empty. I'd it possible the epg data is loaded from a certain channel?
 

grahamlthompson

Distinguished Member
Thanks for the help. Tried that already. Completely powered down, removed the power cable, left for half an hour still no epg. I'm surprised no one else has mentioned anything. It takes a minute before all the channels load, but when they do, they're empty. I'd it possible the epg data is loaded from a certain channel?

The epg data is carried on each multiplex. The BBC MUX are usually the fastest option. It takes about 20 mins or so to populate the full epg from scratch.
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom