1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Purchase - problem?

Discussion in 'Blu-ray & DVD Players & Recorders' started by conington, Jun 18, 2002.

  1. conington

    conington
    Active Member

    Joined:
    Mar 6, 2002
    Messages:
    259
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Colchester
    Ratings:
    +6
    Just received my Toshiba 510 from Webelectricals, great service ... delivered within 24 hours of the order.

    I have one small problem, on the same day as receiving the player, Snow Dogs was delivered so the new film was put straight in and watched, about halfway through the film there was a pause (I assume the layer change) however the pause remained completely locking the player, the only way that I could resolve it was to power off at the wall. When returning directly to the scene there was no evident pause and the film ran fine.

    I am of course concerned that there may be a fault with the new player (I haven't had a chance to watch any other discs yet). Has anyone any ideas or previous experience of such a problem.


    Many thanks
     
  2. gringottsdirect

    gringottsdirect
    Active Member

    Joined:
    Jan 11, 2002
    Messages:
    2,896
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    71
    Location:
    50 Rue St Georges, Paris.
    Ratings:
    +27
    conington,
    Normally a "freezer" disc will do so every time at the precise spot in your player.
    You have played it through without problem, at least once.
    Try more discs, if this happens again, probably you have a faulty Dvd player, simply needs replacement.
    Alternatively, try your Snow Dogs on friend's players and see what happens, maybe your disc needs replacing instead.
     
  3. Ricky27

    Ricky27
    Active Member

    Joined:
    Feb 8, 2002
    Messages:
    1,701
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Norwich
    Ratings:
    +144
    I had the same problem when playing my new Speed disc last night,during the opening titles the disc just paused,i couldnt get any reaction from the remote so tried switching of at the player,nothing.
    Like you i had to switch off at the socket and then it was fine.
    Smoething to keep an eye on i think,mine was bought from Richer though.
     
  4. conington

    conington
    Active Member

    Joined:
    Mar 6, 2002
    Messages:
    259
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Colchester
    Ratings:
    +6
    Thanks for the feedback, the same has happened with the second film I watched, Gladiator, I have contacted Webelectricals and they will be picking up the unit for inspection and either repair or replacement .... Just a shame that they wouldn't just swapo teh machine, I will now be without DVD for at least 4 days!
     
  5. Squirrel God

    Squirrel God
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I would insist on a replacement (assuming you reported the fault within 28 days of delivery).

    Incidentally, most retailers will not exchange or refund electrical goods without first confirming the fault themselves (either in home or at base).
     
  6. conington

    conington
    Active Member

    Joined:
    Mar 6, 2002
    Messages:
    259
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Colchester
    Ratings:
    +6
    Your point is reflected in Webelectricals response, they picked up the unit yesterday (10 days after purchase) and stated that they would replace the unit once the engineers had taken a look, I'll give them today but will start chasing tomorrow.
     

Share This Page

Loading...