NEW Lyngdorf Mp 60 2.1 issues

ar2ro

Novice Member
Guys in need of bit of help. So i jumped on quaity audio badnwagon, got Lundorf MP 60 2.1 and paired it with some Revel speakers. And stereo is working all fine. Have problems with HT integration. since i am a newbie comign of a long time denon experience wondered whether you could help me with

1. have huge eARC problems with XR 83A90J - no sound whatsoever - reading it might be sony related but wondered whether anyone got a workaround.

2. Doe MP support source switching? so if i turn on a source (NVIDIA) it does turn on the TV on appropriate source but the Source on teh processor stays the same as before need to manually switch it to nvidia. Anything i am doing wrong ?

3. the HDMI CEC control doesnt really work - despite it being enabled in the set up

4. Is there a HDMI passthrough to TV when MP 60 is on sleep?

5. for stereo listening should i use room perfect or bypass it?

anmy other tips and tricks appreciated
 

MrMrH

Active Member
Sony TVs can be a bit of a pain, I only just managed to get mine to accept Dolby Vision a couple of days ago when I started going through the settings.
Ensure you are using HDMI3 and the inputs submenus you have enabled “Enhanced” (in my case it was enhanced with Dolby Vision) for that HDMI port.
Loads of menus and complexity with Sony so I’d start there, on mine even thou the changes to the Apple TV I needed to do it again after I’d fixed the settings on the TV.
 

ggwoodland

Well-known Member
With my LG C9 I needed CEC enabled on both my TV and MP50 for eARC to work. Works great - all the streaming apps work fine. As for Sony I don’t know you would need HDMI CEC enabled on your MP60.
As for source switching I have disabled CEC a on everything else and just use the Lyngdorf Web UI on my iPad or the remote to switch.
There is no pass thru on the MP50 and I presume MP60 as well. Sometimes if I want to watch a Youtube Video I just use TV sound but otherwise I use my MP50.
As for stereo I listen to hi Res Apple Music via USB and that sounds great with RP engaged so I would say leave RP on for stereo- george
 

alebonau

Distinguished Member
its work of the devil basically... ARC and CEC... best avoided...

switch it all off...

then sit back and enjoy what you have
 

MrMrH

Active Member
To enable CEC on my Sony A80J I needed to do this:
In the Home Screen menu at the top go to the right to your Google icon, then go down to settings.
  • Channels and Inputs
  • External Inputs
  • Bravia Sync settings
  • Auto TV on
  • Bravia Sync device list
… ensure that it is enabled for the necessary HDMI inputs
 

Ma88

Standard Member
I have the same issue with my A90J connected to my MP60 2.1. After a while, timing seem to be random, I would get an error saying there is a communication error and sound is forced to go back to the TV sound system. Very annoying, at this point, I'm not sure if it is my MP60's issue or if its the Sony issue. The only way to solve the problem is to restart the TV. It is very annoying, but I am not even sure how I can trouble shoot this.
 

orange55

Well-known Member
With my LG C9 I needed CEC enabled on both my TV and MP50 for eARC to work. Works great - all the streaming apps work fine. As for Sony I don’t know you would need HDMI CEC enabled on your MP60.
As for source switching I have disabled CEC a on everything else and just use the Lyngdorf Web UI on my iPad or the remote to switch.
There is no pass thru on the MP50 and I presume MP60 as well. Sometimes if I want to watch a Youtube Video I just use TV sound but otherwise I use my MP50.
As for stereo I listen to hi Res Apple Music via USB and that sounds great with RP engaged so I would say leave RP on for stereo- george
@ar2ro I agree with George here. For music I always use RP. Another tip is getting room knowledge to 100%, which really improved the music for me over 98%.
 

NangNang

Member
It is just the crappy new HDMI Board of Lyngdorf to be honest. I have same issues since start with Lyngdorf.

Even my old Yamaha was able to turn on and off all devices properly, without any issues. But Lyngdorf is not able to do so, according to Lyngdorf Support Sales Team. Its a limitation of HDMI 2.1 Board.
 

NangNang

Member
But then some people are more into new technology and inter-communication of equipment and others will tell you to turn it off and say it never worked properly.

My experience is it always worked when setup correctly and then all the HDMI CEC features were super handy.

eARC on the other side works fine. But I barely use it, as all my media feed to the TV is via Apple TV or Shield, so I don't need eARC really.
 

NangNang

Member
This was the answer of Lyngdorf:

"On/off via CEC is not supported on the MP-60, as this requires the HDMI board to be active in standby, and with the power consumption of that board we can not meet the EU legislation for standby power consumption. Volume control via CEC works once the unit is active."

Hence basically it is a joke that they say HDMI-CEC is available on the MP60.

HDMI-CEC per Definition is a feature to control all units attached with 1 Remote!

That starts from turning it on, to adjusting volume and potentially using that remote to select entertainment you wish.

In short, It is basically not available on MP60. However, this funny volume control is available once MP60 is turned on, i.e. I can change volume with my Apple TV 4K remote control.
 

audiom3

Standard Member
With my LG C9 I needed CEC enabled on both my TV and MP50 for eARC to work. Works great - all the streaming apps work fine. As for Sony I don’t know you would need HDMI CEC enabled on your MP60.
As for source switching I have disabled CEC a on everything else and just use the Lyngdorf Web UI on my iPad or the remote to switch.
There is no pass thru on the MP50 and I presume MP60 as well. Sometimes if I want to watch a Youtube Video I just use TV sound but otherwise I use my MP50.
As for stereo I listen to hi Res Apple Music via USB and that sounds great with RP engaged so I would say leave RP on for stereo- george
Hi @ggwoodland I too have an LG C9 and a Lyngdorf (MP60 2.1). My issue is every time I shut down the system and then turn it back on, the LG automatically selects 'Internal Speakers/optical'. So I have to go into the settings and select eARC every time. To be clear, it works properly for you without having to do this step?
 

ggwoodland

Well-known Member
If you turn off the Lyngdorf before the TV yes - all I surmise is that the C9 detects no signal and switches to internal speakers - if you turn off the Lyngdorf first then C9 then no - eARC is maintained - George
 

audiom3

Standard Member
If you turn off the Lyngdorf before the TV yes - all I surmise is that the C9 detects no signal and switches to internal speakers - if you turn off the Lyngdorf first then C9 then no - eARC is maintained - George
Ok, thank you for that tip. I'll figure out how to add a delay to my Logitech Harmony remote.
 

audiom3

Standard Member
If you turn off the Lyngdorf before the TV yes - all I surmise is that the C9 detects no signal and switches to internal speakers - if you turn off the Lyngdorf first then C9 then no - eARC is maintained - George
It absolutely does not work in my setup. I tried shutting down the Lyngdorf first. No eARC. I tried shutting down the LG first. No eARC. No clue what the hell is going on...
 

ggwoodland

Well-known Member
It absolutely does not work in my setup. I tried shutting down the Lyngdorf first. No eARC. I tried shutting down the LG first. No eARC. No clue what the hell is going on...
Can’t really test at the moment as decorators have dismantled my setup. But you have the 2.1 board and mine is the previous version that supports eARC but not 2.1 so there must be some differences - although I do notice it does revert to internal speakers sometimes on Blu ray startup and ATV - all I think of is someone is timing someone out - george
 

audiom3

Standard Member
Can’t really test at the moment as decorators have dismantled my setup. But you have the 2.1 board and mine is the previous version that supports eARC but not 2.1 so there must be some differences - although I do notice it does revert to internal speakers sometimes on Blu ray startup and ATV - all I think of is someone is timing someone out - george
Ok thanks. I've gone ahead and moved everything (HDMI) over to the MP-60 2.1. That way I only have to deal with manually enabling/selecting eARC is when I watch an internal LG app. A band-aid for now as I want to run some sources directly into the OLED (namely my video streamer for Plex movies).
For trouble-shooting, I've had to 'hard reset' the TV and processor, unplug all HDMI connections, wait X amount of time (10-15mins longer = better), plug ONLY eARC cable in and fire them both up. Then you can start plugging in other HDMI connections. This did happen with my prior Anthem AVM60 processor. But in that case, it showed ARC (wasn't eARC capable) as enabled but I'd get no audio at all. So a bit different issue but could be related. Either way, I solved the ARC issue back then with the Anthem by installing a CEC-blocker on a Roku Ultra that I had plugged into the Anthem. The LG would always 'think' the Roku was the connected device and not the Anthem. So the LG would disable ARC knowing the Roku couldn't possibly decode any audio. That's my theory anyway. I have another CEC-blocker lying around, so I'll experiment on the devices connected to the MP-60 (right now just the ShieldTV, PS5 and Xbox X) when I garner enough motivation.
 

Ma88

Standard Member
Guys in need of bit of help. So i jumped on quaity audio badnwagon, got Lundorf MP 60 2.1 and paired it with some Revel speakers. And stereo is working all fine. Have problems with HT integration. since i am a newbie comign of a long time denon experience wondered whether you could help me with

1. have huge eARC problems with XR 83A90J - no sound whatsoever - reading it might be sony related but wondered whether anyone got a workaround.

2. Doe MP support source switching? so if i turn on a source (NVIDIA) it does turn on the TV on appropriate source but the Source on teh processor stays the same as before need to manually switch it to nvidia. Anything i am doing wrong ?

3. the HDMI CEC control doesnt really work - despite it being enabled in the set up

4. Is there a HDMI passthrough to TV when MP 60 is on sleep?

5. for stereo listening should i use room perfect or bypass it?

anmy other tips and tricks appreciated
Hi ar2ro, are you still having problem with your MP60 2.1 eARC with the XR83A90J? If so, I encourage you to email Lyngdorf support ([email protected]) and report the issue. The more we flag this issue to them the more likely they will be able to find a fix. Thanks
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom