New LG OLED, new 7.2 Denon, PS5, still no ATMOS!

NewInCT

Novice Member
Hello everyone. First post and I look forward to your knowledge and input. I've done a tremendous amount of research on this online and still can't seem to find a clear answer, or at least one that my limited experience will allow me to comprehend. Here is what I currently have:

1) LG OLED 77" GXPUA
2) Denon 7.2 model X2700H capable of Dolby Atmos
3) A PS5 for 4K Blu-Ray use
4) Speakers: All Klipsch - 1 SW, FL, C, FR, Floor Surround L, Floor Surround R and two Rear In-Ceiling speakers

As I understand it, my speakers listed above make up a 7.1 channel system. For the last week I have been running a 5.1 system, having just installed the in-ceiling speakers today but the speaker wire is not yet run. I'm running Ultra High Speed HDMI cables with Ethernet (2.1) from the eArc on the TV to the eArc on the receiver and then running my Frontier cable box into the cab/sat input on the receiver via HDMI 2.1 and the PS5 to the receiver's Blu-ray input via HDMI 2.1.

While watching TV, I only get sound out of the FL and FR speakers until I select the "OPTION" button on the Denon remote and select "Stereo All". Then I get sound out of all 5 speakers. When watching a 4K Blu-ray on the PS5, I get sound out of all 5 speakers but the "Format" on the Denon Remote App is reading "PCM" on the "Input" screen. I went through the process on the PS5 under "Sound" and switched from PCM to Bitstream and then attempted to do the same while watching a Blu-ray, as recommended by Sony, but Bitstream is greyed-out in this menu. According to Sony, this must be switched to Bitstream also in order for the PS5 to play sound in Dolby Atmos.

My passthrough is set correctly and I followed all steps correctly when setting up my receiver. My question is, is Dolby Atmos not being "triggered" because I have yet to utilize the last 2 channels of my 7.2 receiver (the in-ceiling speakers)? I've read that Dolby Atmos can be used with a 5.1 receiver but it has to be set up as a 5.1.2 system. I'm just wondering if I have a setting that is incorrect somewhere or if things will self-correct once I connect my in-ceiling speakers to the Surround Back L&R channels on my receiver and then re-run the speaker setup procedure.

I would like to point out that I am currently watching a movie on Netflix and the receiver is showing "DD+ DSur TV" without me changing a thing.

As you can see, I appear to have some strange things going on and different issues with my cable box, my PS5 and now Netflix. Any recommendations would be greatly appreciated. I hope I've provided sufficient information. Thanks very much!
 

CaptainJames

Well-known Member
Until you connect up your ceiling speakers and re run the speaker set up and Audyssey, the amp will not output an Atmos signal. Then it will technically become a 5.1.2 system (7.1 refers to 5.1 + 2 Surround Back speakers. Take care when running the setup wizard that you choose the correct configuration.

With regard to the current sound options, if the source is outputting 2.0, then you can choose to listen to it in stereo, or upmix it to 5.1 using DD Surround as you describe. You just need to select the desired ouput using the green "movie" button on the bottom of the remote.
 

dante01

Distinguished Member
I'd question locating the ceiling speakers at the rear of the room as opposed to having them above or slighly in front of your seated location (Top Middle). This isn't really conducive with Dolby's own guidelines as to where Atmos ceiling speakers should be located in a 5.1.2 setup. Here's the setup as it should be if following Dolby's advice:

by default 2021-01-11 at 14.37.59.png




If you've located your ceiling speakers at the back of the room and behind where your surround speakers are then they are not correctly located for the portrayal of Atmos.

As already suggested. You have to specifically assign the ceiling speakers as being ceiling speakers in order for the AV receiver to then acknowledge Atmos and or portray it. A setup has to include at least 2 ceiling, upward firing or height speakers if wanting to portray Atmos soundtracks. This is opposed to designating them as being Back Surrounds which is what you appear to have done?
 

NewInCT

Novice Member
I'd question locating the ceiling speakers at the rear of the room as opposed to having them above or slighly in front of your seated location (Top Middle). This isn't really conducive with Dolby's own guidelines as to where Atmos ceiling speakers should be located in a 5.1.2 setup. Here's the setup as it should be if following Dolby's advice:

View attachment 1439366



If you've located your ceiling speakers at the back of the room and behind where your surround speakers are then they are not correctly located for the portrayal of Atmos.

As already suggested. You have to specifically assign the ceiling speakers as being ceiling speakers in order for the AV receiver to then acknowledge Atmos and or portray it. A setup has to include at least 2 ceiling, upward firing or height speakers if wanting to portray Atmos soundtracks. This is opposed to designating them as being Back Surrounds which is what you appear to have done?
Thank you....this is all fantastic advice and information. I actually have only mounted the speakers in the ceiling, fortunately in the correct position based on the diagram you have included. I have not yet run the speaker wire but I plan on doing that tonight. I was concerned because the only two channels I have left on my receiver are labeled “Rear Back Surround“. Based on what I’ve been reading, I was under the impression that I needed a receiver that had channels that were labeled “Height Speaker” in order to get Dolby Atmos. I’ve now learned from a few of you that my rear surround channels are assignable and I just need to ensure that I do the set up process correctly and I will be able to achieve Dolby Atmos sound. I’m very happy that I don’t need to buy another brand new receiver! Fingers crossed when I run the speaker wire and do the set up again within the receiver tonight. Thanks again guys!
 

dante01

Distinguished Member
7 channel Atmos enabled AV receivers allow you to reassign the BACK SURROUND terminals and associated applification for use by 2 Height, Ceiling or upfiring speakers. the configuration post this new assignment obviously no longer has any provision for the inclusion of back surrounds within that setup. If you wanted an Atmos setup that included both the associated Atmos speakers as well as a pair of back surrounds then you'd need at least a 9 channel AV receiver. THe same terminals in such a setup would be utilised for either the Atmos speakers or a pair of back surrounds.

A 7 channel AVR can only have either back surrounds or the Atmos speakers and not both. THe configurations you carry out prior to then running the auto calibration will assign the amplifications use accordingly.


Here's the wiring for your proposed 5.1.2 setup in association with your AV receiver:

by default 2021-01-11 at 21.57.57.png
 
Last edited:

Adam M

Active Member
Forgive me, I’ve not read your entire thread but just a quick question, have you enabled eARC on the tv? I have the CX previously the C9 connected to my Sonos arc sound bar. It was only when I swapped the TVs that I happened on the setting to enable the eARC and suddenly my sound bar came alive and my sonos app confirmed atmos.

The menu to enable eARC is not obvious to find and separate from telling your tv to output sound over ARC hdmi. You might need to Google it.

i found this:

 

dante01

Distinguished Member
Forgive me, I’ve not read your entire thread but just a quick question, have you enabled eARC on the tv? I have the CX previously the C9 connected to my Sonos arc sound bar. It was only when I swapped the TVs that I happened on the setting to enable the eARC and suddenly my sound bar came alive and my sonos app confirmed atmos.

The menu to enable eARC is not obvious to find and separate from telling your tv to output sound over ARC hdmi. You might need to Google it.

i found this:


He's not even the speakers required for Atmos connnected to his receiver. The issue isn't caused by ARC or eARC.
 

NewInCT

Novice Member
He's not even the speakers required for Atmos connnected to his receiver. The issue isn't caused by ARC or eARC.
Well, I’m officially stumped....I connected the Dolby speakers to the back surround channels and re-ran the Denon setup assistant through Audyssey. All went well until it was time to listen for sound coming from my speakers after the setup. I only got music out of the FL and FR speakers. I started over and got the same result. I went forward and made sure that my eArc was enabled on my LG GX but the most I could get is “Multi In + DSur” on cable and a 4K Blu-Ray on the PS5. For those of you PS5 fans out there, there are two audio settings that must be changed from PCM to Bitstream. One is in the general settings once the console is turned on and the other setting is changed once a disc is actually being played. Even with my Dolby speakers hooked up, I continue to have a problem where I am unable to select Bitstream while the disc is playing....it remains greyed out and PCM is defaulted. I can’t help but get the feeling that a setting is off somewhere. Here is what the Denon Remote App is reading during a 4K Blu-Ray. Any thoughts?
 

Attachments

  • 7966664D-2431-4509-A05A-4122A1DDA545.png
    7966664D-2431-4509-A05A-4122A1DDA545.png
    81.7 KB · Views: 52
  • 4BDCDB12-6700-46D1-BF27-B2C3300C497A.png
    4BDCDB12-6700-46D1-BF27-B2C3300C497A.png
    86.9 KB · Views: 55

CaptainJames

Well-known Member
Well, I’m officially stumped....I connected the Dolby speakers to the back surround channels and re-ran the Denon setup assistant through Audyssey. All went well until it was time to listen for sound coming from my speakers after the setup. I only got music out of the FL and FR speakers. I started over and got the same result. I went forward and made sure that my eArc was enabled on my LG GX but the most I could get is “Multi In + DSur” on cable and a 4K Blu-Ray on the PS5. For those of you PS5 fans out there, there are two audio settings that must be changed from PCM to Bitstream. One is in the general settings once the console is turned on and the other setting is changed once a disc is actually being played. Even with my Dolby speakers hooked up, I continue to have a problem where I am unable to select Bitstream while the disc is playing....it remains greyed out and PCM is defaulted. I can’t help but get the feeling that a setting is off somewhere. Here is what the Denon Remote App is reading during a 4K Blu-Ray. Any thoughts?

I don't know anything about the PS5, but it looks like you have configured your speakers incorrectly. Your amp thinks you have Dolby Surround left and right connected, but you need to have Top Middle Left and Right configured.
 

NewInCT

Novice Member
I don't know anything about the PS5, but it looks like you have configured your speakers incorrectly. Your amp thinks you have Dolby Surround left and right connected, but you need to have Top Middle Left and Right configured.
When configuring the receiver, it only gave me 2 options for Atmos speakers.....upfiring atop the front speakers and upfiring atop the surround speakers. I chose upfiring atop the surrounds because it was an Atmos option and it let me adjust the speaker height off the floor, which I selected as 8’ (unless I read that incorrectly). It did give me an option for in-ceiling speakers, however, the setup assistant did not indicate that it was an Atmos option so I was concerned that it was going to have an affect on the sound. I’ll run it again and select the in-ceiling option and see if that changes anything.
 

dante01

Distinguished Member
Start from scratch.

Firstly, ensure the speakers are connected as I previously posted:
by default 2021-01-11 at 21.57.57.png


Now configure the AV receiver's AMP ASSIGN settings as follows:

  • Set MAIN ZONE to 7.1
  • set AMP ASSIGN to TOP MIDDLE (not the Dolby Speaker options you've selected)
*Note that the Dolby options are in reference to yupward firing speakers which you've not got and are not using. You need to select the TOP MIDDLE option!


On the rear of the sub, ensure that the sub is configured as follows:

  • Set its Volume or Gain to about 10 o'clock
  • Set phase to 0°
  • Set the frequency filter to its highest setting or a dedicated LFE option if it has one

Now connect the Audyssey mic and run the calibration.

Post calibration, set all speakers as being SMALL via the AV receiver's speaker configurations and set the associated crossover filters accordingly. Do not set these filters any lower than the AV receiver determined.
 

CaptainJames

Well-known Member
When configuring the receiver, it only gave me 2 options for Atmos speakers.....upfiring atop the front speakers and upfiring atop the surround speakers. I chose upfiring atop the surrounds because it was an Atmos option and it let me adjust the speaker height off the floor, which I selected as 8’ (unless I read that incorrectly). It did give me an option for in-ceiling speakers, however, the setup assistant did not indicate that it was an Atmos option so I was concerned that it was going to have an affect on the sound. I’ll run it again and select the in-ceiling option and see if that changes anything.

This is where it can get confusing - the Dolby Speakers on the set up only refer to upfiring Dolby speakers. Ceiling speakers need to be configured as Top Middle speakers, even though they are not identified as Dolby speakers. The height adjustment you refer to is the height for upfiring speaker to ceiling, not ceiling to floor.

As above, always best to follow the manual when you are not sure!
 

dante01

Distinguished Member
The AVRX2700 has specific options for ceiling speakers, in this case the option should be TOP MIDDLE. Only use the HEIGHT options if using HEIGHT speakers mounted on the front or rear walls.

by default 2021-01-12 at 13.52.37.png




Again, use the TOP MIDDLE option.
 

NewInCT

Novice Member
This is where it can get confusing - the Dolby Speakers on the set up only refer to upfiring Dolby speakers. Ceiling speakers need to be configured as Top Middle speakers, even though they are not identified as Dolby speakers. The height adjustment you refer to is the height for upfiring speaker to ceiling, not ceiling to floor.

As above, always best to follow the manual when you are not sure!
I redid the entire setup process and made sure to select “Top Middle” speakers and followed the above instructions exactly. Still no Dolby Atmos. I’m at a loss. The receiver is capable of Atmos, I’m running eArc on the LG GX to eArc on the Denon receiver and eArc is turned on by default on the TV settings. The first two pics are of the Denon Remote App while watching a Dolby Atmos 4K blu-ray and the next two are while watching HD cable:
 

Attachments

  • 69D5C26C-9C20-410A-AE66-D93FFFA49001.png
    69D5C26C-9C20-410A-AE66-D93FFFA49001.png
    81.5 KB · Views: 33
  • 0F8A9440-10B5-4967-BCC9-F8076BBE4D0A.png
    0F8A9440-10B5-4967-BCC9-F8076BBE4D0A.png
    86.5 KB · Views: 31
  • D42CC066-5F3F-4C94-B933-AEDC2952AE98.png
    D42CC066-5F3F-4C94-B933-AEDC2952AE98.png
    83.1 KB · Views: 30
  • CD6B1094-AD6F-4685-8F57-8D49D0E9A730.png
    CD6B1094-AD6F-4685-8F57-8D49D0E9A730.png
    97.1 KB · Views: 31

dante01

Distinguished Member
The AV receiver is configured and setup correctly. The issue is with how you've configured the sources and their digual audio output. You are streaming PCM audio data to the AV receiver from these sources which cannot convey Atmos metadata. The devices need to be configured so that they BITSTREAM the audio as opposed to decoding it themselves and outputting it as PCM.

Onboard the TV and in association with the ARC and eARC setting, there's options to determine what is output. Set these to AUTO or PASS THROUGH. THis equates to BITSTREAM on an LGE TV.

Onboard ypur Blu-ray player, go into the Audio output settings and set the HDMI audio output to BITSTREAM. THis is called AUTO on Sony players. Also ensure that the setting entitled SECONDARY AUDIO is turned OFF.

It has to be noted that if accessing some TV content that some channels natively broadcast using 2 channel PCM. HD channels more commonluy use Dolby Digital and the very few UHD channnel tend to use DD+. REgardless, the format used will not mean everything on that channel will be anything more than 2 channel in nature.

Anyway, the issue you have now isn't one with the AV receiver's setup. THe AV receiver is now fully configured so that it will decode and portray Atmos if and when it detects the associated metadata. It will only do this if a source is actuallyt outputting this metadata to the AV receiver packaged with DD+ or TrueHD encoded audio. There is also instances whereby it can be sent to the AVR in association with PCM data using Dolby MAT, but this is of no consequence in this instance and only applies to sources such as the Apple TV, XBoxes and Windows PCs.

You'd also be advised to configure any other sources you have so that they BITSTREAM as opposed to have their audio output set to PCM. If you've a TV STB then ensure that this is set to the DOLBY option gor its output and not set to PCM. The PCM option will simply downmix any and all audio to hust 2 channel PCM.
 

CaptainJames

Well-known Member
As above. Your speakers are now configured and outputting correctly. But they can only output what you input - PCM will not give you atmos.
 

NewInCT

Novice Member
The AV receiver is configured and setup correctly. The issue is with how you've configured the sources and their digual audio output. You are streaming PCM audio data to the AV receiver from these sources which cannot convey Atmos metadata. The devices need to be configured so that they BITSTREAM the audio as opposed to decoding it themselves and outputting it as PCM.

Onboard the TV and in association with the ARC and eARC setting, there's options to determine what is output. Set these to AUTO or PASS THROUGH. THis equates to BITSTREAM on an LGE TV.

Onboard ypur Blu-ray player, go into the Audio output settings and set the HDMI audio output to BITSTREAM. THis is called AUTO on Sony players. Also ensure that the setting entitled SECONDARY AUDIO is turned OFF.

It has to be noted that if accessing some TV content that some channels natively broadcast using 2 channel PCM. HD channels more commonluy use Dolby Digital and the very few UHD channnel tend to use DD+. REgardless, the format used will not mean everything on that channel will be anything more than 2 channel in nature.

Anyway, the issue you have now isn't one with the AV receiver's setup. THe AV receiver is now fully configured so that it will decode and portray Atmos if and when it detects the associated metadata. It will only do this if a source is actuallyt outputting this metadata to the AV receiver packaged with DD+ or TrueHD encoded audio. There is also instances whereby it can be sent to the AVR in association with PCM data using Dolby MAT, but this is of no consequence in this instance and only applies to sources such as the Apple TV, XBoxes and Windows PCs.

You'd also be advised to configure any other sources you have so that they BITSTREAM as opposed to have their audio output set to PCM. If you've a TV STB then ensure that this is set to the DOLBY option gor its output and not set to PCM. The PCM option will simply downmix any and all audio to hust 2 channel PCM.
An interesting thing happened last night. After searching the bowels of the internet for days and after being on with Sony Tech Support for almost an hour (even they didn’t know about this), I found this very brief article last night on the PS5 from a guy in the UK that I hope may help to someone here. I do know that many out there were experiencing my problem online. As you gentlemen stated, my receiver was configured correctly, however, I still wasn’t getting Dolby Atmos when watching a 4K blu-ray because “Bitstream” was greyed out and I was stuck with the console outputting in PCM. Under “Accessibility” you have to turn off the “Screen Narration” feature, which speaks to you as you toggle through the PS5 menu. I haven’t a clue what one has to do with the other but the second I did that, I was able to switch the console from PCM to Bitstream and instantly, Dolby Atmos appeared on the front of the receiver. Now on to my cable box. It’s on the HDMI 1 input (cab/sat) on the receiver but during the setup process and during all of my searching, I do not recall seeing anything regarding “Bitstream” to the HDMI 1 input. I’m even more curious now because my PS5 setting was within the console itself so, in theory, the settings on the TV and receiver must be correct. This is your old standard HD Frontier cable box. Is it possible that it just isn’t capable of outputting in Bitstream and giving me Dolby Atmos while watching TV?
 

Attachments

  • C7EEFB67-2CE1-43BC-AA00-03D45B58B9C7.png
    C7EEFB67-2CE1-43BC-AA00-03D45B58B9C7.png
    135.6 KB · Views: 36

dante01

Distinguished Member
Bitstream isn't a format and simply means conveying the digital audio as it was originally packaged.

You are very unlikely to get Atmos audio in association with HD TV broadcasts. I'm assuming that you are in the USA, but here in the UK you'd only get Atmos TV broadcasts via a satellite or cable service and only if the services provides access to UHD encoded video channels via a UHD 4K compliant STB. I've no experoence of your cable box, but this appears to suggest that such boxes wouldn't have any 4K UHD capabilities:


As such and depending upon what the channels encoded HD broadcasts with, you'd at best get Dolby Digital 5.1 if and when the conytent being broadcast includes it.

As I implied, I've no experience of your STB so cannot help with the configuration options you have or how you'd set the box to output Dolby Dihital or Bitstream audio? You'd want to set it to an audio output option that bitstreams the audio as opposed to setting it to PCM though.
 

dante01

Distinguished Member
Regarding the PS5, you may also find this of interest:

Additional settings need to be made if wanting to bitstream audio sourced via Blu-ray or UHD film discs. This is more often than not something many owners are not aware of. This was also the case with the PS4.

 
Last edited:

NewInCT

Novice Member
Regarding the PS5, you may also find this of interest:

Additional settings need to be made if wanting to bitstream audio sourced via Blu-ray or UHD film diss. This is more often than not something many owners are not aware of. This was also the case with the PS4.

Yes, it’s very strange because it was at this very setting where Bitstream was greyed out until I disabled Voice Assistance in the main menu. As the article suggests, this setting is separate from the setting under Audio in the main menu of the PS5. That setting is easy to change from PCM to Bitstream, but the second needs to be done while a disc is playing, pulling up the settings menu, clicking on the circle with the three dots and then scrolling down to audio where it is defaulted to PCM. Again, mine would not let me select Bitstream until I disabled Voice Assistant.
 

CaptainJames

Well-known Member
An interesting thing happened last night. After searching the bowels of the internet for days and after being on with Sony Tech Support for almost an hour (even they didn’t know about this), I found this very brief article last night on the PS5 from a guy in the UK that I hope may help to someone here. I do know that many out there were experiencing my problem online. As you gentlemen stated, my receiver was configured correctly, however, I still wasn’t getting Dolby Atmos when watching a 4K blu-ray because “Bitstream” was greyed out and I was stuck with the console outputting in PCM. Under “Accessibility” you have to turn off the “Screen Narration” feature, which speaks to you as you toggle through the PS5 menu. I haven’t a clue what one has to do with the other but the second I did that, I was able to switch the console from PCM to Bitstream and instantly, Dolby Atmos appeared on the front of the receiver. Now on to my cable box. It’s on the HDMI 1 input (cab/sat) on the receiver but during the setup process and during all of my searching, I do not recall seeing anything regarding “Bitstream” to the HDMI 1 input. I’m even more curious now because my PS5 setting was within the console itself so, in theory, the settings on the TV and receiver must be correct. This is your old standard HD Frontier cable box. Is it possible that it just isn’t capable of outputting in Bitstream and giving me Dolby Atmos while watching TV?

As above I have no knowledge of your cable box, but if it's only HD you are unlikely to receive any Atmos programming, you need something that provides 4K with Atmos audio.

The PS5 is perhaps not the best choice for a 4K Blu ray player.
 

TomBarbeau

Novice Member
Thanks ! Just got my PS5 tonight and couldn’t figure out why Bistream was greyed out. So glad i stumbled on your post.
 

DragonUnleashed

Novice Member
CaptainJames and Dante, i want to thank you for all the info and patience you shared, while helping the Topic Starter .

I just stumbled across this topic searching the topic: ps5 dolby atmos .

This thread however had nothing to do with me, but i started reading and just was baffled how nice, helpful and patient you two were.

Helped newinct set up his sound correctly,

NewinCt also kudos to you because you posted the solution you found for the grey bitstream. Most people when they find a solution the just apply it and leave the question and Topic open, without sharing the found solution, still having the other forum people searching for answers, or have internetsearchers with the same question, without an answer.

I do want to say that without captains and Dante, the set-up wouldn't still have been correctly even if topicsstarter had found the "how to get bitstream" ungreyed.

The combination of the two made it so you can enjoy it to the maximum. !

So i want to say thank you peeps for your time.. things like this should be said, you dedicated yourselves helping others, used precious time doing so.. for free.. so your guys rock!


That said, PS5 is a great gaming console, for media though it's not really it's very odd for Sony not to have it be able to use dolby atmos everywhere, especially as it's being used more and more. Only to use dolby atmos on 4kuhd and not gaming and streaming is just unconsumerfriendly.

That's why for streaming i still use my xbox one s, this supports dolby atmos on all streaming apps. Series and movies using dolby atmos just give that awesome extra.

The PS5 is a great gaming device though!

Hope you all stay helpful. Thanks !
 

The latest video from AVForums

LG G1 OLED EVO Review (OLED65G1)
Subscribe to our YouTube channel

Latest News

Astell&Kern launches the SE180 portable player
  • By Andy Bassett
  • Published
Disney picks up Sony's cinema releases post Netflix in US
  • By Andy Bassett
  • Published
What's new on Netflix UK for May 2021
  • By Andy Bassett
  • Published
Sony unveils X-Series wireless speakers
  • By Andy Bassett
  • Published
AVForums Podcast: 21st April 2021
  • By Phil Hinton
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom