1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New here - Sony DAV S550 Problems

Discussion in 'Home Cinema Buying & Building' started by kevin harrison, Apr 20, 2003.

  1. kevin harrison

    kevin harrison
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi, I've only just found this place and need some advice about my Sony DAV S550.

    I purchased my machine in late August 2002 and some problems have occured.

    1 - The left hand channel has stopped working

    2 - I have had a problem with subtitles from the start, I thought this was a daft Sony idea to make subtitles more accessable. Having done a search here I understand it's a known issue.

    3 - Some discs (all regions) will sometimes not load, all I get is a message saying reading, and nothing else.

    4 - Region 1 discs have now stopped working completly.

    What do you think, return my machine to Paul Taylor in Peterborough and demand a new machine or just accept him mending my machine ?

    Has anyone else had any of these problems ?

    Thanks for any advice.

    Kevin Harrison.
     
  2. Dutch

    Dutch
    Well-known Member

    Joined:
    Dec 5, 2002
    Messages:
    2,598
    Products Owned:
    1
    Products Wanted:
    3
    Trophy Points:
    106
    Location:
    North Yorkshire
    Ratings:
    +282
    Hi Kevin,

    As the machine is still under warranty, I'd return it to Paul Taylor and ask for a replacement. Good luck.

    Steve
     

Share This Page

Loading...