1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New firmware for Cyberhome ADL528 gives progresive scan

Discussion in 'Blu-ray & DVD Players & Recorders' started by Stuart Wright, Dec 3, 2002.

  1. Stuart Wright

    Stuart Wright
    AVForums Founder Staff Member

    Joined:
    Jan 24, 2000
    Messages:
    13,821
    Products Owned:
    6
    Products Wanted:
    2
    Trophy Points:
    167
    Location:
    Birmingham, UK
    Ratings:
    +9,559
    I don't recall any progressive scan option in my Cyberhome 528 previous to the upgrade to 10.01 I just installed. Now there is an interlaced/progressive option. Anyone tried the progressive scan output?

    Latest firmware available from
    http://www.cyberhome-europe.de/support/adl528.htm
     
  2. peebaa

    peebaa
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    sorry this is not related to your query but it sound like youve updated your machine successfully with rev 10.01.

    i however have lost the picture but still have sound, do you know what the problem may be, please help!!!!:confused:
     
  3. nunew33

    nunew33
    Standard Member

    Joined:
    Jun 5, 2002
    Messages:
    1,735
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Lytham St Annes, where people are put out to grass
    Ratings:
    +2
    Spectre, did the firmware have any effect on its ability to fly?

    Is this the same useless piece of junk of your other post?
     
  4. Stuart Wright

    Stuart Wright
    AVForums Founder Staff Member

    Joined:
    Jan 24, 2000
    Messages:
    13,821
    Products Owned:
    6
    Products Wanted:
    2
    Trophy Points:
    167
    Location:
    Birmingham, UK
    Ratings:
    +9,559
    I got the player from my in-laws and upgraded it pretty much immediately. I'm fairly sure the poor video output problems (unable to cope with high contrast) existed before the upgrade.
    The upgrade itself worked perfectly. And in the menu afterwards I noticed the progressive output options.
    Films played with picture and sound after the upgrade but both DVDs I *tried* to watch on it got stuck a good way in. I don't know whether this was due to the firmware or something specific in this player. I feel it was probably the player.
    It had no aerodynamic qualities whatsoever and the new firmware didn't seem to make it any firmer.
    When it hit the patio slabs it made a hollow, metalic bang and the tray flap flew off. It's mostly hollow and metalic.
    Frustrated by the lack of spectacle I went downstairs and threw it at the ground a couple of more times just to get my money's worth. I felt better afterwards - unwrapped the Acoustic Solutions player and watched the rest of Blade II without any problems.
    It's also played Stuart Little 2 no problems. That's all so far.
    The Cyberhome has too many firmware problems to be recommended. There are better, cheaper players on the market.
     
  5. Thor

    Thor
    Member

    Joined:
    Oct 18, 2001
    Messages:
    490
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Above UK
    Ratings:
    +2
    This may help you here. The main site is here. Hope this cures your problem.:)
     

Share This Page

Loading...