New Dell laptop - Issue with wireless

Simon244

Standard Member
Hey guys,

I just got a brand new Dell 1564 laptop from PC World. (DELL Inspiron 1564 Black at cheap prices | PC World)

Was setting it up last night. So I've switched it on and ran through everything that's come up. I joined the wireless network named 'Simon'. This is the network that has been set up already via my old laptop. I use Virgin 20MB broadband and have a Netgear router. With my old laptop I had to set up Virgin Wireless software on it.

On this Dell one it picks up the network and I can access the net, but most of the time it's either pretty slow or connection times out.

I thought perhaps I needed to set up the Virgin wireless stuff on my computer but when attempting that it's unable to find my wireless adapter in the set up process which confuses me even more.

No idea what to do here. Frustrating getting a nice new laptop and the net connection is rubbish.

Appreciate some help.
 

Simon244

Standard Member
I think I need to run the Virgin wireless manager software after reading Virgin's FAQs. However this doesn't find my wireless adapter card even though it's clearly there as I've been able to access the net.

Could it be a problem with the laptop configuration / drivers or something?
 

spyder viewer

Distinguished Member
You've gone to "network and sharing centre" and selected "set up a new connection or network". You've joined "Simon", made it a home network and also the default. How many bars are filled on the wireless signal strength meter in the status bar? Are you joined to the right network? How many users on your wireless network?
 

Simon244

Standard Member
You've gone to "network and sharing centre" and selected "set up a new connection or network". You've joined "Simon", made it a home network and also the default. How many bars are filled on the wireless signal strength meter in the status bar? Are you joined to the right network? How many users on your wireless network?

Yeah that's correct.

The signal strength is very high.

The network was set up on my old laptop and was only used by that. That's my old Fujitsu Siemens laptop where the net has always been solid and fast. On this Dell box it's just awful. I had both the laptops on in my room side by side, the old one worked fine, whilst the Dell was either slow or connection timed out 90% of the time.

I'm going to try updating some drivers when I get home. I can't think of anything else. Just wondering if something was configured incorrectly when setting the laptop up before I purchased it.

I can't see how a brand new i3 Dell laptop on 20mb net connection can be so poor.
 

spyder viewer

Distinguished Member
Can't add any more. The Dell gurus party hard so they like to sleep in but I'm sure they'll be along soon and quickly get you straight!;);)
 

Simon244

Standard Member
Mate of mine uses a Dell and he said he uninstalled all the crap they put on there for wireless etc and used the standard Windows stuff.

Will give that a try.
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom