Networking problems


Distinguished Member
My mum's internet network seems to be plagued with problems and I'm getting to the point that I'm at a loss of what to do. I'll try to keep it as simple as possible to explain;

We started with a single Netgear DG834GT. She has an ADSL line from Talk Talk. Everything was fine but there was next to no usable wifi upstairs (large house, thick walls), so Talk Talk supplied a DSL-2640R router, and I installed both routers (the DLink downstairs, connected to master socket, and the Netgear upstairs, connected to the DLink via ethernet), with the same SSID and password to create one large wifi network.

That worked fine for a while, then one day devices stopped connecting to the strongest wifi signal, instead insisted on trying to connect to the primary wifi access point (the DLink). I couldn't figure out why, so I changed the SSID's and passwords of both to create two individual networks (at this point the SSID's became "DLink" and "Netgear")

This worked fine for a while until one of her lodgers couldn't get on the internet one day, and stupidly pressed the reset button on both routers, then of course nothing worked.

So last week I spent 4 hours trying to set it all up again as it was, and found a host of problems. I got both routers working again, on separate SSID's (DLink and Netgear) and my Mac could connect to both, get internet from both, as could my iPhone. The problems arose that my mums laptop (a Dell laptop running Win7) would connect to the SSID, but it would say in the sys tray that there was no internet access. I tried different channels, rebooting routers, rebooting the laptop, deleting the known/previous networks on the laptop, manually adding, automatically finding, etc etc. For some reason, it was treating the SSID's as "2" - i.e. instead of showing it was connected to "DLink" it was showing as connected to "DLink 2", and "Netgear 2" instead of "Netgear" - no idea why...

Anyway, I left it with it working - there was usable internet being transmitted via wifi on both DLink and Netgear routers, connecting via ethernet to either router worked fine, and her laptop also connected to DLink (not "2") and worked. Until this morning when I get a text saying that "Netgear 2 is back and can't get internet. Also printer doesn't work" (the printer is a wifi enabled Kodak printer)

So I'm at a loss now what to do. I can't work out whether the problem is network or laptop related, and to be honest I've had enough of it now. I just want it to go back to being simple and just working, not having to go over there every week to try and reboot/reconfigure the entire thing. The annoying part is, she has paying lodgers, so she has to be able to provide working internet. But I'm getting to the point that I just want to get a pro in to strip it down and start again, because whilst I know a little bit, I'm far from a pro and I'm getting stumped...

At the risk of trying to explain the hardware config, here's how it's set up;

Downstairs : master BT socket, ADSL line goes to DLink router. Wifi turned on, SSID = SMC_DLink

Upstairs : ethernet cable running from DLink router to Netgear router (to pipe internet). Wifi turned on, SSID = SMC_Netgear

Both routers have same password, just for ease. Both are on same IP range (192.168.1.x), with DLink being primary as 1.1 and Netgear box being 1.2 (manually set in Netgear settings to be on IP 1.2 - Dlink box is issuing DHCP from 1.3 and up). There are a few hardwired cables from from DLink box; 1 to the control unit for solar panels on the roof, and another going to terminal points in upstairs rooms - one of the lodgers likes to use the hardwire to skype, and a previous had a hardwire for PS3 gaming.

One part of me wants to ditch the whole set up, get a single, strong-power wifi access point, like a Cisco Aironet (ideally one that does power over ethernet) that I can install somewhere that will provide a strong and equal signal to both the upstairs and downstairs, and simply use the DLink box as an ADSL point, pipe the internet signal to the wifi access point and leave it at that. But on the other hand, I don't want to have to go out and buy new, and probably expensive, hardware, to make it work - especially if I get a call/text a week or two later saying the internet is working again.....

Little help?


Distinguished Member
Generally, you don't seem to be doing anything obviously wrong and it sounds like you've got wi-fi interference (from the neighbours or between your routers) issues, but here's a few pointers:

Don't bother looking for some "router with a strong signal" - wi-fi transmit power is limited in law and most kit is (and always has been) close to the permitted max. In any case, client devices all transmit too, so even if you could find a "more powerful router" you'd need to change all your client devices for ones with "more power" to transmit in the reverse direction, and obviously that's not going to happen. Cicso (or anyone else) have no magic bullets that make their AP's "stronger" than anyone else, no matter what the marketing BS says - they are all bound by the same laws about Tx power. The approach you are taking with multiple hot spots and cabled backhaul is the correct one.

For chapter and verse on using multiple routers, see the FAQ in this forum, but briefly, connect them together using their LAN and not their WAN/Internet ports, disable DHCP Server on all but the one connected to your ISP and give them compatible but differing IP addresses (sounds like you've already done all of this.)

If you've reset a router that functions as you DHCP Server, the DHCP leases can get in a mess, but after a 24 hours or so, that should have sorted itself out. If you've manually set any IP addresses, you need to ensure they don't conflict with each other or any addresses assigned by DHCP.

It is something of and Internet Myth that wi-fi clients are always "hunting for the best signal." There's good reasons why they don't. Unfortunately, when/if a client roams is largely in the gift of the equipment designer and there's not much you can do about it. Note that it is the clients that decide if/when to roam, not "the system." "Sticky clients" is a very well known problem "in the business." With dissimilar SSID's this point is moot as client won't try to roam at all until thy completely loose connection and start their "get you on the Internet at all costs" search for anything that "works."

When you find "no internet access" it's worth investigating whether it's a wi-fi issue or an IP one. So check the client has a valid IP address, if so ping your router(s) IP addresses and check whether they answer. If so, not a wi-fi or local IP issue. If not, you can suspect wi-fi.

With multiple cells you need to pay attention to the radio channel tuning to remove as much interference between cells as possible. In small SOHO networks I'd set them manually rather than rely on automation. Choose two channels from the set [1,6,11] that best avoid any interference from the neighbours. In the 2.4GHz waveband for the N protocol, there's not enough frequency spectrum to avail multiple "fat" (40MHz) channels that provide the fastest speeds, so we usually restrict 2.4GHz to "thin" (20MHz) channels and accept that top speeds will be halved, but interference is very much reduced. Or in two cell deployment you can opt for one thin and one fat channel, in which case set the channel number as far apart as possible. Note that some routers don't offer "fat" N channels, so the point could be moot.

To ensure you're not using old wi-fi profiles on the clients, set up new SSID names that are dissimilar to anything you've used before thence you can be sure you are binding to the new ones.

Personally I wouldn't use wi-fi for a networked printer, I'd cable it unless there was no other choice. a printer only needs to be "on the network" for a wi-fi client to print to it. However, as wi-fi is getting faster, this is less of a big deal unless you print lots.

Of course, you could be suffering interference from the neighbours. In the flats where I live, everyone has wi-fi and there's no chance of finding a clear (enough) channel in the 2.4Ghz frequency band. It can ablsolutely clobber my wi-fi when next doors router decides to tune to whatever channel I'm using. I long since gave up and shifted to the 5GHz band which thus far I have all to myself.
Last edited:


Distinguished Member
Some of that is very much "over my head" (at least in terms), but I think I get (at least some of) what you're saying.

Neither router is N capable, and are set to offer 802.11b/g. I'm not sure if any client (other than possibly a mobile phone) that connects to them are n capable either.

Channel wise, it could be interference. I use iStumbler on my Mac when I'm setting them up to see the networks within reach, so I can see the channels they are on, and try to pick a channel that doesn't conflict with them. Channels on each router are manually set rather than left to auto. And it's here I noticed problems.

With the primary router (DLink) set to channel 1, I couldn't even get my iPhone or Dell laptop to connect. Just kept saying cannot connect. Change to 6, and I can connect, but the Dell laptop was finicky with being able hold onto internet connection (network connection was fine, but it dipped in and out of getting internet). The secondary (Netgear) router seemed happiest on 11.

I guess I'm gonna have to go over there again and try changing the SSID's to something completely different - not even remotely the same as what they were.

Roaming, which was my first choice for set up (hence the identical SSID and password) would be ideal, but not really that important. Generally the clients that use the upstairs (secondary) router tend to stay upstairs and the clients that use the downstairs (primary) router tend to stay downstairs. And they can always manually switch if need be.

Printer wise, I've no idea why it's misbehaving. I think it is wifi linked, rather than ethernet, but I'd need to check. Not an awful lot of printing happens, but when you do want to print and it won't work, that can be one of the most frustrating things ever. Me personally, I like USB attached printers. Much less effing about (usually), but everyone wants to be "un-cabled" these days I suppose.....

Now, regarding DCHP and IPs. I want the Primary and Secondary routers to have static IPs - purely so I know "where" they are, and makes it easier for me to connect to them for settings. I know they are bother on 192.168.1.x, with Primary being 1.1, and I think I've got the secondary set up correctly as 1.2 (like I said, I set the secondary, in it's LAN settings, to be 1.2, and I think after that I set the DCHP range on the primary router to administer from 1.3 onwards.)

Can I go into the primary router and change it to 192.500.1.1, connect the secondary router to it via ethernet and go into it's settings and tell it to be 192.500.1.2, turn off DHCP on the secondary router, and tell the Primary to start issuing IPs for clients from 192.500.1.3 (with both routers have 255 subnet mask thing), or is changing the numbers in the IP going to cause issues? I know an older router I had years ago had the IP of, but nearly all routers I've had since have been or


Distinguished Member
Can I go into the primary router and change it to 192.500.1.1, connect the secondary router to it via ethernet and go into it's settings and tell it to be 192.500.1.2, turn off DHCP on the secondary router, and tell the Primary to start issuing IPs for clients from 192.500.1.3 (with both routers have 255 subnet mask thing), or is changing the numbers in the IP going to cause issues? I know an older router I had years ago had the IP of, but nearly all routers I've had since have been or

Your routers need to have unchanging IP addresses so the clients can "find" the Internet connected one, so it's best to manually assign their LAN IP address. The 192.168.1.X addressing scheme you've described is fine - I wouldn't bother changing it - just ensure that the secondary router has it's DHCP Server turned off - this is really important, otherwise you could have multiple DHCP Servers active which can issue conflicting IP addresses and/or addresses with invalid "default gateway" values which can render clients Internet-less. It's quite funky when this happens as client can work locally always, but they get Internet one day and not the next and can simple "disappear" off the network if they receive conflicting IP addresses.

You head is probably spinning, so I won't get into a huge treatment of IP address, but you can't use 500 for the 2nd octet - all the number have to be 0-255 and there are rules about which values you can/can't use, but as I say the 192.168.1.X scheme you've described looks fine so I wouldn't bother changing it.

When you change IP addresses on SOHO routers and/or reset them back to factory default, you blow away the DHCP lease tables they've built up over time and the DHCP server "starts over" and can issue DHCP Leases that conflict with those already "in hand" in the clients. SOHO routers DHCP general issue IP addresses that "last" for 12-24 hours before they need to be renewed. In normal use this is all sorted out automatically. But if you've just done a reset, the DHCP Server looses it's list of leases and start with an empty one and this can issue leases that conflict with old ones. Once all the old leases "in hand" in the clients have aged out and the clients have sought new ones, this problem effectively sorts itself out. A week on, you should be clear of these issues, but it's something to bear in mind if anyone goes and resets the routers again: Post reset, IP addressing can go wonky for a while unless/until you force all clients to renew their leases (a reboot often does this, though in things like Windows there's some magic commands you can use.)

Bear in mind that iStumbler may not show you everything - if it's anything like InSSIDer, it only shows Access Points (routers) - not client devices or "other" users of the radio frequencies such as microwave ovens, video senders, car alarms, baby monitors etc. You may have interference sources that you are unable to "see" with a wi-fi sniffing tool. As you've discovered, without pro. RF monitoring equipment, sometimes you just have to use a trial and error process to find some channels that work acceptably well.


Distinguished Member
BTW - for your printer, beit wire or wi-fi connected, it's best if it also has an IP address that doesn't change so people can always "find" it. Either manually assign it on the printer, like you've done for the router (don't forget to bump the DHCP range if you do so) or find whatever IP address the DHCP Server has assigned to the printer and tell the DHCP Server to "always assign this IP address to this device." Most DHCP Servers will let you do this, though the language they use to describe it seems to vary somewhat. Usually it's keyed on the MAC address (ie MAC address ZZ:XX:CC:VV:BB:NN always gets IP address A.B.C.D)


Distinguished Member
THanks for that. Printer I'll look into once I've got the LAN and WAN sorted. What's annoying is the Netgear router has a MUCH better settings page, including one to see the attached devices, and set them a static IP (and I think an "always use" if the IP is within the DHCP set) whereas the DLink is a bit clumsy; you can see the attached devices and their IPs but not really seem to be able to do anything with them. There is a manually set IP for MAC address' section, but it's a PITA to use once DHCP has started rolling out IPs (and there doesn't seem to be a "cancel/renew" IP function.

Anyway, I pulled everything apart, set up both routers on the table next to each other, pulled the ADSL line so we're only working internally, linked both routers together by ethernet, and connected my MacBook to the Dlink via ethernet and began trying to configure them. So far I've,

- Changed the SSID on both routers (DLink/Primary now = DOWNSTAIRS, and Netgear/Secondary now = UPSTAIRS)
- kept password the same for both
- have the Dlink set to dish out DHCP from onwards
- turned DHCP on the Netgear off, and manually told it to use as it's own IP - which it seems to be doing.

They both seem to be transmitting WAN and internet fine (only tested with my MacBook and iPhone so far - have yet to test with the Dell Win7 laptop - which no doubt will cause me problems.... I hate Windows...)

DLink/Primary settings;


Netgear/Secondary settings;



Distinguished Member
Is it feasible, that once I find out the MAC address of the printer (which for the time being will have to be connected over wifi, until I get a short ethernet cable for it), I go into the settings for the Netgear/secondary router, reserve an IP for it (for example,, and apply it there - even though the printer would be connected to either the SSID for the DLink/Primary router, or hardwired to the DLink/Primary router, and the IP of 1.20 is inside the DHCP range?


Distinguished Member
Since the DHCP Server in your secondary router is out of use, reserving an IP address there won't do anything useful. In any case, you wouldn't want to, you need to reserve all IP addresses in the functioning DHCP Server in the primary router.

The DHCP process is somewhat independent of the physical transport - it doesn't much "care" which SSID/ethernet port your device is connected to. DHCP works using broadcast traffic (meaning all workstations see it) so if your printer is Associated (to use the technical term) with wi-fi on router 2, the printer (or anything else) will send out a DHCP Request which router 2 will receive over wi-fi and broadcast out of it's ethernet ports by which path it will reach the DHCP Server "listening" in router 1. The replies go back by the same path, but (hopefully obviously) in the opposite direction, (actually the replies are also broadcast, so everything sees them.)

A lot of printers cite their MAC Addresses (note the plural) on the "test" pages if you prod the relevant buttons to make it produce one. A network printer may have multiple MAC address, one for wired one for wi-fi (though I have seen printers that are wi-fi only.) When you reserve your IP address, make sure you use the correct MAC (or set up one for both.) IP addresses are assigned to "interfaces" not "devices," so a device with multiple network interfaces (one wired one wi-fi) such as a laptop or a networked printer, could quite possibly have/need multiple IP addresses - one for each network interface (effectively one for each MAC address - wired and Wi-Fi will be different MAC's.)

Alternatively, let the printer find IP through dynamic (automatic) DHCP at which point it will be listed in the DLink DHCP table. From there, you can thence copy the MAC and paste it into the edit box, set the IP you want and apply it. Then a reboot of the printer (or wait 24hours) and it should hopefully pick it up.

It's nice when the DHCP Server has a "one click" "make this address permanent" button, but not all do and there's nothing for it but to do it the old fashioned way. In seriously olden days, you had to set this kind of thing up by editing text files! Hurrah for modern web interfaces.

Another thing to watch out for with wi-fi printers is that the wi-fi on the printer is set to "client" or it might be called "infrastructure" mode which makes it function attached to your router like any other wi-fi client devices. You'll know if you'r on the right track because it will want to know the SSID and passphrase of your router.

There's another form of wi-fi called "ad-hoc" mode which works without using the wi-fi of your router. Ad-hoc mode wi-fi is used for creating little self contained work groups of a few devices without any contact with the outside world. It's a bit like Bluetooth paring, though TBH that isn't a very good metaphor. If you have your printer in "ad-hoc" wi-fi mode, client device can talk to it directly. (And it will be advertising an SSID which you should be able to see with things like iStumbler - could it be the source of your "Netgear 2" SSID...?)

The trouble is wi-fi clients can only be Associated with one Wi-Fi network at a time, so they'd either be Associated with the "infrastructure" network provided by your routers, or the "ad-hoc" network which your printer is participating, but not both at the same time.

So if you printer is offering choices of "ad-hoc" or "infrastructure" mode operation, you want the latter so it participates in the wi-fi LAN's availed by you routers. Basically, just avoid anything that looks like "ad-hoc" mode wi-fi. You have an "infrastructure" wi-fi system.
Last edited:


Distinguished Member
Thanks again. I booted the printer up, looked for the new SSID, found it, and connected to it, then ran a test print and it's all working. Dlink (and Netgear for that matter) routers showed it as 1.35 in their attached devices table, and both showed the same MAC address for it (of course this was on wifi only - I understand what you're saying about having a different MAC address for it's wired NIC). I've left it like this for now, as 1) it's working, and 2) the problem with the DLink (you can see in the pic above) is that once a MAC address has been assigned an IP, it disappears from the drop menu in the IP column - and since there's no "one click fix/reserve address" button, the only way (that I can see) to set a static/reserved address for an IP is to wait for the lease to renew and clear the old one.

What I think I might do next time I'm over there (I'm home now) is reduce the DHCP range from the other end (so instead of finishing at 1.254, pull it back to 1.253) then assign 1.254 to the MAC address of the printer manually (I noted it down already) so that when it next connects, it *should* automatically go directly to 1.254 (maybe - not sure if I have to tell the printer it should be going for 1.254 like I told the Netgear router to go for 1.2)


Distinguished Member
It's not the worst idea to bump the DHCP range down even further so you've got a few addresses outside the DHCP range to manually assign. Most SOHO LAN' are only going to have a few dozen devices at most so DHCP range of 50 addresses should be sufficient. If ever you do need 100's of IP addresses, you wouldn't be using a cheapy SOHO router!

Since you already have some low range addresses assigned, I'd bump the ending DHCP range down rather than bump the beginning address up to avoid another round of DHCP lease hassles. It (ahem) "should" be fairly painless to drop the end address down to 50, 100 or 200 or so. I realise I'm tempting fate with that statement. :D


Distinguished Member
Thanks again for your advice and pointers, Mick. As I understand it, it's been up and running without problem since I was over Sunday resetting it all.

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom