Network plan and how to add VPN

James7514

Novice Member
Hi guys,
I currently have a network setup and it runs really well, but i would like to add VPN to the entire network.

As i have lots connecting through it, i would like to do this via my Router. I have put a quick plan of my network underneath:

Media Server Running Plex + PS3 IPad Air
[Hardwired] Iphone (s)
Netgear R7000 Router as WiFI Access Point [Wifi] Macbook Pro
Ipad Mini

[Hardwired]

PS4
Internet - - - - - - - - - - - - - - - - - - - - - > Virgin SuperHub 2 [hardwired] XBOX One
(wifi OFF) TIVO
Roku 3

So, My virgin superhub currently does all the DCHP and workings, as well as connect me physically to the internet. Because this is underneath my TV it also controls all of my PS4 etc which are connected to it via ethernet.

On the other side of my flat is my R7000 which does all my Wifi work. The R7000 is sat in access point mode. It does however have 2 devices connected to it via ethernet, my HP Media server and also my Ps3 in another room.

I would like to enable a VPN on one of my routers. This will route all traffic into a VPN and out to the internet. The logical choice would be the superhub2, but this doesn't enable VPN.

My only choice therefore is if i can enable it on my R7000.

Is this something which is possible? At the moment as the R7000 is in access point mode it doesn't handle an DHCP. Can i shut off the superhub DHCP and enable it on the R7000 without stopping all of the devices hardwired to the superhub from working?

Any advice greatly appreciated!
 

James7514

Novice Member
it has totally changed my network plan that i neatly typed!!

Essentially the R7000 is the Wifi access point, with only 2 devices connected to it via Ethernet.

The Virgin Superhub is connected to the R7000 via an ethernet cable and then also connected to PS4 etc via ethernet. The superhub is then connected directly to the web.
 

The latest video from AVForums

Podcast: CES 2021 Special - Sony, LG, Panasonic, Samsung, TCL and Hisense TV news and more...
Top Bottom