Network Drive Letter updates - Help please

Discussion in 'Desktop & Laptop Computers Forum' started by Messiah, Oct 17, 2004.

  1. Messiah

    Messiah
    Well-known Member

    Joined:
    Apr 22, 2002
    Messages:
    7,620
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Ratings:
    +338
    I have just added some new HDDs to my server and made some changes to the drive letters. Unfortunately, when I now bros=wse the Fileserver from another PC on the network it is not showing the revised drive letters. Even if I do a refresh it will not update the drive letters. If I browse a drive that is showing with the old drive letter it does actually show the contents of the new drive that actually belongs to that drive letter.

    This is very annoying. Anyone knoe=w how I can foce My Network Places to show the updated drive letters?

    Thanks.

    Yours

    Frustrated :confused:
     
  2. explicitlyrics

    explicitlyrics
    Active Member

    Joined:
    Apr 26, 2003
    Messages:
    1,147
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    NW London
    Ratings:
    +17
    try deleting the auto added network shares on the remote computer. Sometimes the refreshing doesnt work for some reason because although the physical disk has changed - the drive letter is still there so windows may not update the name.
     
  3. Messiah

    Messiah
    Well-known Member

    Joined:
    Apr 22, 2002
    Messages:
    7,620
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Ratings:
    +338
    Thanks. Done that. But no difference. I've even switched both the fileserver and the network PCs off to try to get themn to rescan the network but no luck.

    Also, despite setting sharing on the new drives it won't display those letters for the newly added drives.
     
  4. KraGorn

    KraGorn
    Active Member

    Joined:
    Aug 30, 2003
    Messages:
    4,745
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    68
    Location:
    Warrington
    Ratings:
    +27
    This is typical of the rubbish that is M$ networking .. while I'm no expert it's clearly a problem with network browsing and the action of the Browse Master, that fact you can see the drives when you know they're there indicates this.

    I must say I've not come across a case where the drives refuse to show up for a long time, however you may want to try manually mapping them:

    1) open a command prompt
    2) on a client machine, decide on a drive letter you want to use and the name of the shared drive you want to map it to, then enter this command

    net use driveletter: \\servername\sharename

    for example:

    net use r: \\myserver\f

    to map R: to drive F on the server. If all goes well you'll now be able to see R: in My Computer and Network Neighbourhood hopefully.

    By default this mapping would also be permanent, it may just prod the browse master into action. It's possible to fiddle with the Browser service (nothing whatsoever to do with Internet Explorer BTW!) if this doesm't work.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice