Network can't find my printer

Oneeasygeezer

Standard Member
I'm not sure whether it was the result of of the Win 10 OS update or not but my Epson ET - 4750 printer has disappeared from my network it was originally connected via USB and there were no issues with printing from the PC, however when I came to scan some documents to the PC the software Read Iris Pro 17 couldn't see the printer, it now no longer shows under devices, file manager or in the routers devices, after a checking different things without success and being in a hurry to get the scanning completed I decided to disconnect the USB cable turn off the Wi-Fi and connect via Ethernet.

Despite all that the printer doesn't show on the network, I’ve pinged the IP address and it's there with no lost packets, but it's still not showing, I've tried the following ipconfig/flushdns, ipconfig/release, and ipconfig/renew once again all to no avail, but I can still print to it using either a USB connection or connecting it up via ethernet despite it not showing on my network, so now my very limited network knowledge/ ability is exhausted, HELP
 

John7

Well-known Member
I would uninstall it completely through control panel and reinstall software/drivers again (download latest from Epson). Run a CCleaner Registry sweep before you install the new software to clear out any remnants.

Could be an easy fix (!?)
 

Oneeasygeezer

Standard Member
I would uninstall it completely through control panel and reinstall software/drivers again (download latest from Epson). Run a CCleaner Registry sweep before you install the new software to clear out any remnants.

Could be an easy fix (!?)
Hi John thanks for you response I should have said I ran the Epson connection checker which reports all being well and at the same time there was a software update which I applied, and I also ran Norton Utilities premium to clear cache, and any registry remnants. I've also emailed Read Iris tech support and am currently awaiting their response.
 

John7

Well-known Member
I would still uninstall and reinstall it, Windows update may have broken it.
 

Oneeasygeezer

Standard Member
Thanks John I uninstalled the scanner software and reinstalled with no change, I then did as you suggested and uninstalled the printer software and after reinstalling it I'm now back up and running, thank you very much for your help. :)
 

John7

Well-known Member
Glad to help! Many years of Windows experience here, back to the (nightmare) days of Windows 3.1!
 

Oneeasygeezer

Standard Member
It was much appreciated John, the thing which threw me was that I could print to it but not but not scan from it which lead me to think it was a scanner issue until I realised the printer didn't show up anywhere, then I was just totally confused.
 

The latest video from AVForums

Podcast: REL T/9x Subwoofer + Bowers & Wilkins PI7 Reviews, AV Shows in a Pandemic and more
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom