Question Netflix unblocker no longer working after TV update (Sony Bravia)??

Discussion in 'General TV Discussions Forum' started by RipGroove99, Apr 14, 2016.

  1. RipGroove99

    RipGroove99
    Member

    Joined:
    Dec 21, 2014
    Messages:
    16
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    4
    Location:
    United Kingdom
    Ratings:
    +0
    Firstly I don't really know what forum this belongs in so please feel free to move this thread to the correct place.

    Also please lets not make this thread about the morals of watching a different Netflix region.


    For the last few months I've been a paid Netflix member and subscribed to www.unlocator.com which gives me access to U.S. Netflix even though I'm in the UK, they do this by registering my IP address on their system and giving me DNS addresses to enter in to my desired device. This was all working fine until yesterday when my TV updated itself (Sony Bravia KDL-55W80 - Android).

    So I've tried all the usual fixes whenever there is a problem, clearing DNS addresses, restarting everything, logging out of everything etc etc etc but for whatever reason my TV now only displays UK Netflix content.

    Worth noting that both my iPhone and a second Sony Bravia (non Android) in another room still displays U.S. content as normal so this MUST be an issue with just the one (main TV in my living room).

    Does anyone know how to either fix this OR roll back my TV's last update?


    I've asked www.unlocator.com for help but now for some reason a few months in they are telling me Android TV's are not supported so cannot offer any support, even though its been working finr for months.

    The other option would usually be to put these DNS addresses directly into my router and then ALL my devices would automatically use them but 1.) I'm not sure I can do that with my crappy SKY Hub and 2.) I'm not sure how that would affect the rest of my internet usage, I don;t want everything routed through the U.S.

    I did read somewhere that maybe I could connect a wireless router to my SKY hub via a WAN port and set the DNS addresses to that and then plu my TV into the new router and that that would somehow work?

    Help, I need to finish watching the Walking Dead...
     
  2. himpressive

    himpressive
    Active Member

    Joined:
    Sep 28, 2004
    Messages:
    82
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    11
    Location:
    Hemel Hempstead, Hertfordshire
    Ratings:
    +7
    Have you checked your TV settings to be sure that there is no location setting that identifies your region as UK?
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice