• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question Netflix sound issue help ?

roblatus

Standard Member
I have a Panasonic TX55CX680 tv, Humax FoxT2 freeview box and a Samsung blu ray player.

I have the Humax connected to one of the non arc HDMI on a Roth Sub Zero 3 sound bar.

The sound bar is then connected to the Arc HDMI on the TV from its own arc HDMI

Blu ray straight to TV.

Everything works fine.

Except, when i try and watch something via the netflix app on the TV the sound is not working correctly, its just a really harsh sort of distorted noise.

When i use the TV speakers its fine. Also when i use netflix via the blu ray player through the sounder, its fine. However the netflix on my blu ray player does not show things in 4k :-((

I have the same sound issue when i play video files from my NAS drive via the TV, however accessing the NAS from the blu ray and everything is fine.

I think i have tried everything tbh but maybe i am missing something and am desperatly trying ti find a solution.

Everything worked fine with my previous panasonic sound bar, however the sub woofer was making a popping sound which seems to be a common issue from searching the internet so i changed it for the Roth.

Thanks in advance for any assistance
 
Last edited:

Ghostrider

Active Member
You have it connected up wrong but it's a simple fix.

You need to connect the HDMI ARC on the soundbar to the HDMI ARC on the TV - this will allow the TV to pass its internal audio to the soundbar.

The HUMAX should be connected to one of the two non-ARC HDMI inputs and the BluTay should be connected to the final HDMI input on the soundbar.

If you connect the BluRay to the TV you are not delivering the best possible audio to the soundbar.
 

roblatus

Standard Member
I apologise

I do actually have the Humax in a non-arc HDMI on the soundbar. The arc HDMI on the sounder is then connected to the arc HDMI on the TV.


I have now connected the blu ray to the other non arc HDMI on the soundbar.

Netflix still not outputting sound correctly from the TV.

Player ok, youtube ok, everything else ok.

I tried connecting just the TV to the sounder with no other devices attached with just an optical cable and its still the same.
 

roblatus

Standard Member
The only way i can get the sound to work fine for netflix via the TV is to connect the headphone out of the TV into the line in of the sounder. Surely i shouldn't have to do this?

I will stick with this as a solution for now, but i have sent an email to Panasonic regarding this issue.

Not very hopeful they will have a solution tbh :-(
 

Ghostrider

Active Member
OK so you are definitely connected from the Soundbar HDMI ARC to HDMI 2 on the TV.

Under SOUND menu item what is Speaker Selection set to - TV or HOME CINEMA.

Under SOUND menu item what is SPDIF Selection set to?
 
Last edited:

roblatus

Standard Member
I have hdmi 2 on TV (arc) connected to the arc hdmi on the soundbar, definitely.

Dvd and humax box connected to the other hdmi ports in soundbar.

Speaker setting in tv set to home cinema

I read something about toggling the spdif from auto to pcm for netflix. So I tried this too, it didn't work. Lol

Its working OK now that I have the headphone out from the tv into the line in on the soundbar, TV is set to built in speakers with volume turned all the way down and then use line in on soundbar and controlled the volume with soundbar remote.

It's not right though is it? It should just work through the hdmi when the tv is selected regardless of what I am watching on the tv, ie netflix, iPlayer, YouTube etc.
 

cinephile177

Novice Member
I apologise

I do actually have the Humax in a non-arc HDMI on the soundbar. The arc HDMI on the sounder is then connected to the arc HDMI on the TV.


I have now connected the blu ray to the other non arc HDMI on the soundbar.

Netflix still not outputting sound correctly from the TV.

Player ok, youtube ok, everything else ok.

I tried connecting just the TV to the sounder with no other devices attached with just an optical cable and its still the same.


I'm having similar issues with streaming Netflix sound to a soundbar. I have a Panasonic TX40CX680B tv. and a Cambridge TVB2 soundbar.

Both the optical cable and ARC route are NOT working even when disconnecting all the other devices (cable box/DVD). The panasonic Home Cinema sound option when connected to HDMI (ARC) does not want to connect displaying 'check HDMI connections'. There is no sound from any internet streaming apps. When using optical cable Youtube is fine but no Netflix. Netflix just gives out this horrendous distorted machine gun noise. very disappointed if the headphone out is the only route..

did you get a response back from Panasonic?
 
What i'm thinking is that the Panasonic TV wont output 5.1 via optical or ARC but you have Netflix trying to deliver 5.1 hence the sound issue.

Could you try the below and set the video playing to Stereo

To adjust subtitles on most Blu-ray players, Smart TVs, and set-top boxes:

  1. Launch the Netflix app.
  2. Select the movie or TV show you want to play.
  3. Select Audio & Subtitles from the options panel.
  4. Select your preferred audio or subtitle options.
  5. Press Back to return to the options panel.
  6. Select Play.
 

cinephile177

Novice Member
'fraid that's not working either. Changed from the 5.1 option to stereo and still got the 'machine gun' sound. Could this be a hardware issue from Panasonic? It's unacceptable anyway if I cannot find a way to stream Netflix audio through the sound bar. Strange that all other internet tv apps work.
 

clifflev

Standard Member
Hi did you find a solution with the Panasonic and Cambridge audio tvb2?

I have the same setup and cannot solve the loud machine gun noise when playing Netflix even when changing to PCM and audio within Netflix (deselecting 5.1)
 

Jeni

Novice Member
Hi. I have this issue too. Why is there no fix yet? Seems like a very fundamental feature of a smart television.

I found a temporary (though still very annoying, especially if you're trying to binge watch something) fix.
  • Start your Netflix show then hit pause right away.
  • Menu > Sound > Digital Audio Out Selection
  • Change to Auto (if it's not already).
  • Then, change to PCM.
  • Hit play. Voila.
You must change it away from PCM and hit "Ok" before changing it back to PCM or it won't work.
it changes each time you play a new episode/movie, so you have to do this at the beginning of EVERY show. But at least the sound works.

Hope that helps! Let me know if you hear of a more permanent fix!
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom