Netflix not playing on TX-55HZ980B - latest version of software update 3.686

Paddygyal

Novice Member
Hi all,

Apologies if this has been covered elsewhere, I couldn't find a thread with exactly this issue - if so let me know and I'll delete. We got a TX-55HZ980B in January 2021 from Richer Sounds, and up until a few days ago always accessed Netflix via Virgin. We (finally) got rid of Virgin, and now when we try and access Netflix via the telly, everything works fine until we actually press "play" on something - then we get the message "We're having trouble playing this title right now. Please try again later or select a different title. tvq-pb-101". From my online searches it looks as if this is usually due to the TV not being updated - but I have automatic updates switched on, and there's no update to make (current version is 3.686). Does anyone have any other suggestions? I've tried all of the common suggestions, including logging in and out of Netflix (trying a few different accounts just to see, same issue with all of them), switching everything off completely, and deleting and re-adding Netflix to the Home menu screen (it's still available via Home > Apps so this really doesn't seem particularly significant, as far as I can see there's no way to delete it from the Apps marketplace and re-download it).

Any suggestions gratefully received - I'm going to ring Richer Sounds tomorrow and will update this thread with their advice/input.
 

JayCee

Distinguished Member
Unbelievably sometimes rebooting your router has been known to cure oddities like this.
 

mikej

Well-known Member
You might as well try a factory reset if you haven't already ?
 

Paddygyal

Novice Member
Unbelievably sometimes rebooting your router has been known to cure oddities like this.
Just did a full factory reset (as advised by Panasonic, and the only thing I hadn't tried) - Netflix is working now! Fantastic. Thanks for your reply btw.
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom