Need XP driver for ATI Mobility Radeon 9000

Discussion in 'Desktop & Laptop Computers Forum' started by geordie_blerk, Jan 8, 2004.

  1. geordie_blerk

    geordie_blerk
    Standard Member

    Joined:
    Feb 16, 2002
    Messages:
    39
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I've just re-installed XP Pro on my laptop, which uses the above video subsystem, but after re-installing it doesn't recognise the graphics correctly and I can't find any setup CD's with a driver on it.

    I've checked both ATI's and the laptop manufacturer's (Advent) websites but I can't find a driver anywhere.

    Can anybody point my in the right direction?

    Cheers
     
  2. dUnKle

    dUnKle
    Distinguished Member

    Joined:
    Jan 1, 2001
    Messages:
    15,280
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,279
    Was under the impression this was a one driver does them all thing
     
  3. dgc

    dgc
    Standard Member

    Joined:
    May 1, 2003
    Messages:
    216
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +2
  4. rhinoman

    rhinoman
    Active Member

    Joined:
    Oct 31, 2000
    Messages:
    2,631
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    71
    Location:
    Herne Bay, Kent
    Ratings:
    +33
    Yes the latest cat drivers will be fine if the ones that load automatically with the xp install aren't.

    My laptop has the same chip and its fine with the xp install, then do windows update for thje latest "approved" version.
     
  5. geordie_blerk

    geordie_blerk
    Standard Member

    Joined:
    Feb 16, 2002
    Messages:
    39
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks for all of the suggestions.

    I had already tried the catalyst drivers but it came up with a message saying it couldn't find any ati devices.

    I've downloaded the specific mobility driver from the link supplied by dgc but that also complains about no ati hardware.

    I think my problem is some sort of chipset configuration problem, it's using a SiS 650 chipset and device manager within XP reports an unknown video device.

    To be honest, I can live with it for now because XP is still letting me run in 32bit colour at 1024x768, which is all I would be running at anyway.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice