Need some technical network advice.

spr97ajm

Active Member
Hello all, I need the help of someone with some technical network knowledge.

I have an iPhone 6s on the Sky mobile network, which uses O2’s infrastructure.

When I am out and about, I have good 4G coverage and the phone works fine. When I am at home I have 2 or 3 bars of 4G coverage but I cannot receive calls, though I am able to make outgoing calls, and send & receive SMS messages. People calling me hear an outgoing ring tone, but then instead of getting my answer machine, they are connected to a range of odd, recorded messages saying things like ‘The subscriber you dialled cannot answer the call for the moment, please try again later’. The messages are in English but with a range of different accents including Chinese, American and British English. I can replicate this by calling myself from my home phone.

As I understand it, when the phone detects an incoming call, it should drop to the 3G network to receive it, and this is the behaviour I see when I am not at home. When at home, the phone seems to take too long to drop to 3G, the call never comes through, and for some reason the mobile network routes the call to the recorded messages instead of my answerphone.

Sky insist there’s nothing wrong with their network or my local mast. They sent me a new SIM which exhibits the same behaviour.

Apple say there’s nothing wrong with the phone as I can’t replicate the behaviour at their store. (I have not got ‘do not disturb’ or other such setting active).

If I change the phone mobile data settings and force it to use 3G, then it works fine even when at home.

I previously used the same phone on the Vodafone network without any problems.
Can anyone offer any suggestions? Any advice greatly appreciated.

Thanks. Andy.
 

Steven

Senior Moderator
Test the SIM in another handset and can rule out whether it is network or handset related
 

spr97ajm

Active Member
Thanks,
I've tried it in my other half's iPhone 4S and it works perfectly, but of course that's only a 3G phone so it doesn't help my theory. I don't have access to another 4G device. I'll have to wait until an unsuspecting mate comes round. I'll update here if I make any progress.
Andy.
 

jamster

Active Member
I assume that you have reset your phone to factory settings Restore your iPhone, iPad, or iPod to factory settings, and also checked for operator updates to eliminate any software issues? Update your carrier settings on your iPhone or iPad

If so, it sounds like a problem related to 4G to 3G handover:

4G (LTE) cannot receive voice calls itself. It is a data only network. When a call comes in, the mast signals to the phone to switch over to 3G to receive the call.*

It sounds like that this is not happening fast enough in your case; perhaps a weak 3G signal in your house or some interference - either at your end or to the connection between your mast and (ultimately) Sky's network** - that is slowing down the handover process. The handover is probably not happening before the incoming call times out.

I think this might also explain the different accents your callers are getting; I hypothesize that the "call timed out" signal is being sent back to the operator of the network who originated the call so their customer is getting the recorded message from their own network.

The chances of you getting Sky to fix this in a realistic time-frame are slim, because you'd have to get past Sky's "send a replacement SIM" helpdesk and get your issue escalated to the networks team.

If you really want to do that, it would be helpful to determine whether this is a Sky specific issue, or an issue with all operators using O2 on your local mast.

To do this, I suggest picking up a cheap Giffgaff or Tesco Mobile sim card (both MVNOs run on O2) and seeing if you get the problem on that too.

If you don't get the problem on other O2 MVNOs, then you know if it is a problem with Sky's configuration specifically and you can try to push them to fix it. Just don't take no for an answer and make sure you escalate your calls to a supervisor to get them to pass it to the networks team.

If you do get the problem with other O2 MVNOs, then you know that O2 is not the network for you in your house: perhaps localised network interference. In which case you would be better switching to a different network. Sky is competitively priced but there are others in the same price bracket, running on different networks, which might serve you better, including:

- Plusnet - uses EE's network; and
- iD mobile - uses Three's network.

I hope that helps. Let us know how you get on.

Notes:

* Some operators support Voice over LTE (VoLTE) which allows voice calls on 4G but I don't think that Sky is one of them at the moment.

** As you know, Sky Mobile is an MVNO on O2 but Sky are on record as saying they have build most of their platform themselves so there will be differences in configuration between them and O2, and there will be a connection between O2 and Sky for the purposes of call signalling.
 
Last edited:

spr97ajm

Active Member
Hi, thanks for your comprehensive reply. It sounds like you know what you're talking about, and I'll try your suggestions.

I've already tried restoring the phone to factory settings and making sure the carrier settings are up to date, etc.

I will buy a SIM from another MVNO and see how that goes.

I am able to hear the differently accented recorded messages myself when I call repeatedly from my landline (also Sky), so I don't think that's down to my calling party using different networks.

I have tried to escalate the problem with Sky, but they wouldn't register a complaint from me as the phone works on 3G. They said they don't guarantee 4G coverage and therefore there was nothing wrong, and no basis for a complaint. I tried to escalate to a supervisor, but the operator said I was being rude and threatened to terminate the call. I'll have to try this again and hope that I get a more reasonable operator.

I will update when I can.

Thanks again for taking the time to think about this.

Andy.
 

jamster

Active Member
No problem and good luck.

Just a thought - have you tried setting the carrier manually. I don't know if it will help but it is easy to try:
  1. From the Home screen, tap Settings.
  2. Tap Carrier.
  3. Tap the Automatic slider to Off.
  4. Tap the required network (o2 or Sky, depending on how it is presented - the network will be o2 but Sky can set a SIM card / carrier setting to rename it on your phone - they may have done this).
 

spr97ajm

Active Member
Also see if this option is available on your phone
Is your iPhone 6 or 6 Plus dropping calls on AT&T? Here's the fix!
(I think it might not be, but worth checking and trying each mode if it is)

Thanks, I don't have that option on my phone. I think I used to, but I can't remember if that was when I was on Vodafone or whether it was in a previous iOS software version.
I also tried manually selecting the carrier, but that made no difference.
I hope to pick up another MVNO SIM in the next few days.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom