need advice on rotel 880 A, made in 1987 but gets 'touchy' somnetimes

ivortripod

Novice Member
Rotel 880A have had new since 1987, has been fine but lately is getting sometime problematic.
NB :These issues are the same with headphones* and speakers.
When turned on to receive Fm, from Rotel 830AL tuner, phono off Goldring Lenco turntable or CD from Sony CDP XE330, the audio starts off 'crackling' which stops when you set the amp to mono. After few minutes turning this switch and amp warming up, it usually goes ok, but then later sometimes does not output left channel at all, until you again turn mono switch back and forth. The Optimus Pro X7 speaker cables are fairly new, but all phono cables are some 25 years old.
*Have tried different headphones but with no improvements.
Do I need to look at the state of the Mono switch, do I replace the old phono leads or is it something else...
I have zero experience when it comes to opening up amplifiers, and if the mono switch looks 'iffy' what do I with it ??
All answers very much appreciated :0)
 

Jamie

Distinguished Member
Do you have any switch cleaner spray?
Might not work or be temporary only but it could be worth trying some

Unplug the amp and leave it for a while, then give the switch a good spray while pressing it. I'd then give it a while to dry before plugging back in.
 

ivortripod

Novice Member
Do you have any switch cleaner spray?
Might not work or be temporary only but it could be worth trying some

Unplug the amp and leave it for a while, then give the switch a good spray while pressing it. I'd then give it a while to dry before plugging back in.
Thanks for your reply Jamie, it's a rotary switch but will give this a try, much appreciated :0)
 

Jamie

Distinguished Member
This stuff is pretty good in my experience if you need to buy some

Servisol Super 10 Amazon product

Coincidentally the first review for the item is from a guy who used it to sort out a Rotel Amp with exactly the same problem
 

ivortripod

Novice Member
Should have gone to Specsavers, the Rotel Amp is an RA 820A, sorry!
I am now needing to access the 'Mono/Tone' switch, so urgently need advice on how to get the cover off : as I do not have a clue !!
Cheers.
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom