Quantcast

NAD Receiver (T751) Problem

K

kiwiranger

Guest
Hi Folks

I'm posting this on behalf of a mate who has just bought himself a NAD receiver (T751 as mentioned above). He's managed to muck around with his settings, and now has a major issue with surround sound.

His centre speaker seems to have been set to REALLY REALLY quiet. You can just hear sound out of it if you place your ear right next to it. All the other speakers have no problem.

I've run him through a couple of ideas, and made sure that the centre speaker is set to "ON" and "SMALL" (which it is). I've run the Monster Inc DVD's THX optimiser over his system and it just confirms what I've said above.

Anybody have any ideas?

If we can't get it working by tomorrow, then it's going back to the shop it came from (where they will no doubt humiliate him and fix it in 10 minutes flat).

Thanks

Chris 'kiwiranger' Parke
 

Andywilliams

Active Member
hi kiwiranger
ive been doing some research on the new nad receivers on a american forum quite a few people have experienced problems with faulty channels ie no sound or very little sound i was thinking of buying the nad 762 but these problems seem to be true let me know how you get on thanks gonzo.
 
K

kiwiranger

Guest
Hey Gonzo

Thanks for that info. I'll post any results on this forum.

Ta

Kiwiranger
 
K

kiwiranger

Guest
Well not exactly a solution as such, but mate got his receiver exchanged and is (currently) very happy with new one.

Kiwiranger
 
Top Bottom