• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

NAD C340 - front leds

phlix

Standard Member
I've had my C340 for 6sh years without issues. however, recently I'm unable to turn the volume up beyond about a third without it cutting out and the leds starting to flash on the front. I've tried cleaning it (hoovering the innerds), however it doesn't solve it. Any suggestiions???
 

Spangle2k5

Active Member
It sounds like there is an issue with the power supply.

You could try ringing your local dealer to see what they think, advice is free and the fix may be surprisingly cheap!
 
L

lisa burrell

Guest
phlix said:
I've had my C340 for 6sh years without issues. however, recently I'm unable to turn the volume up beyond about a third without it cutting out and the leds starting to flash on the front. I've tried cleaning it (hoovering the innerds), however it doesn't solve it. Any suggestiions???

sir we own a 340 love it to bits we have had all the lights on the front on
what caused this was banana plugs touching each other in the speaker terminals We have the heavy duty gold ones and there to heavy clumsy for speaker terminals so we bare wire in.
Incidentally we feel this is the only criticisms of this wonderful amplifier we have

in every other aspect its superb. Cant help you with the volume control though
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom