• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

myHTPC, Network Player, Set-Up, MyMovies

Xstyle

Prominent Member
Great festivities everyone!
I've been having some trouble with my Graham Myers built myHTPC for the last couple of years, which is no doubt down to my own IT and networking inability !! Can you help and advise please? I'd very much appreciate your assistance!

The Set-Up:
* The Dune and myHTPC server are connected via HomePlugs (TPLink AV1200) and a Gigabit Ethernet Switch, on Sky Fibre Unlimited. All in the lounge sitting together at the moment.

* dedicated IP addresses are reserved for both on the router, and the Switch lights up to show both as working ok.

Issues:

1) Network
I changed broadband provider a year ago, now on Sky, and the IP addresses needed to be changed.
However I am unable to change the path on the Dune for where MyMovies looks at, for the servers new IP address?
If I revert the server to the old IP address, I also need to change the DHCP range.
Old server IP: 192.168.1.xxx
New server IP: 192.168.0.xxx
DHCP range at moment is 192.168.0.2 to 192.168.1.254
I would prefer to have all as .0 rather than .1 ...however I can't change the network path?

But as the Dune can't read the new Server IP, I tried putting it back to the old one as the path would match, however it still says it can't connect. I did have them running ok yesterday at some point but then they weren't showing up on the LAN! And were connected to the Internet. However only the Dune is now connected to the net, not the server.

Now when the server is on the .1 address, the Dune mostly doesn't even show up. Says it's loading screen then is just blank forever. So I do need to put it back to a .0 IP. But again how do I change the path?
And how do I also get the server online again to the net?

2) MyMovies
My Movies 5 Collection Manager seems to be OK on the PC and iPad but NOT on the server. In the Dashboard of my server, "MyMovies" is blank? In "server folders and Hard Drives" all my existing files are there though. Surely MyMovies should be populated on the server. The error message is:
"MyMovies could not create its database on the SQL Server. The error returned was 'There was a problem creating your new database. Please visit the MM forums for support"

I have tried to restore the last saved database from January 2013, but it always gets to the final stages and fails.

3) AnyDVD does not seem to run at all? The software is up to date in the MM settings on the server. Clicking on the icons does nothing. I have reinstalled and rebooted the server and nothing happens. Shortcut does not work, and even clicking into the Application from the C drive program files folder does absolutely nothing?

What do I need to change please?
I look forward to hearing from you.
Many thanks!
Xstyle
 

MarkE19

Moderator
Your network seems to be a bit of a mess - but I guess you already knew that :confused:

What is the IP address of your router? I'm guessing it is 192.168.0.1 and if so you really want all other devices to have an IP that starts 192.168.0.??? and totally remove all IP's of 192.168.1.??? as it gets more complicated with different subnets ( the .1 or .0 parts of the IP). You could change the subnet mask on all devices from 255.255.255.0 to 255.255.0.0 but this is more work to maintain and does make the network more complex than it really needs to be.
Personally I would go into the router and set the DHCP range from say 192.168.0.2 to 192.168.0.100 and then set on the Dune, server etc. a static IP address that is outside of this range.

Once you have all devices on the same IP range they should then be able to talk to each other and get access to the internet again.

Mark.
 

Xstyle

Prominent Member
Hi Mark,
I have access to the net on both and all good!
All devices are on the .0. range now.

What I can't seem to do now is get the Dune in MyMovies to look at the correct IP address for the server? Any ideas at all please?

I can bypass the whole Dune interface and go into the server files via the Dune and play an ISO, but not get it to work on the normal interface?

ImageUploadedByAVForums1451486479.470586.jpg
 
Last edited:

MarkE19

Moderator
I'm not sure if you can amend the shortcut on the Dune so you might have to delete it and create a new one to get it to point to the correct IP address.

Mark.
 

Xstyle

Prominent Member
I'm not sure if you can amend the shortcut on the Dune so you might have to delete it and create a new one to get it to point to the correct IP address.

Mark.
How?? I've been searching for a couple of days/nights to no avail...
 
Last edited:

Xstyle

Prominent Member
Mark, you sir a Demi-God genius!
That link showed me that my Sources shortcut was all fine, it went into the MM folder and displayed all the files like the ISO etc... Then it occurred to me that thei4 is a folder within all the movie titles called MM itself. Added this as a favourite, and now all great!!

Thank you!

Next problem I have is:

MyMovies and AnyDVD.
On my PC I logged in and had to resynchronise my Collection Management database, from local and online sources. So again on the PC it seems fine.
From File > Connect to Server > .... It fails.
Input the IP Address of the server, but error message says:

"could not connect to the database server. Ensure that the server is running, and that it is not behind a firewall".

On the server itself, the dashboard for MM is all blank.
It shows my username and how many points I have.
On Database back up or restore, it shows the last time I backed up (14/01/13).
However not the back up and re-resync that was performed today on the PC. They are both the same anyway, but I need my server to be connected to MM.

Really appreciate your help!!

Once this is sorted we can look at AnyDVD. :)
 
Last edited:

MarkE19

Moderator
I don't use My Movies so all I can offer here is general advice.

Do you have any mapped drives to your server?
  • If so then are you able to get to your media on the server?
  • If not then try mapping a drive letter and testing you can connect.
Once you have established a working link to the server from your PC try My Movies again and see if it can access the database.

Mark.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom