My o2 not showing allowances

Mr Mot

Established Member
Worked perfectly on my 3GS..

I installed it on my iPhone 4 yesterday, logged in to check my allowances and on the first tab, everything is "0" as if I have no allowance remaining - I know that's not the case and to confirm, I sent a blank text to 21202.

All of the other tabs have the correct information..

Any idea what could be the matter?


Prominent Member
Can't help other than to say it works for me. What plan are you on? I know it shows zero if its something unlimmited, like texts on simplicity plan.

New Start Neil

Distinguished Member
Have you (intenionally or inadvertently) moved to a tariff that has "unlimited" something or other?

Maybe that's why (as per previous suggestion) it's showing zero?


Established Member
I have the same issue. I suspect that it will sort itself out on my bill date (2/7/10). I moved from the iPhone £35 24mth with unlimited data to the new iPhone4 tarriff (same minutes and text but data limit is 500MB/mth).
Perhaps thats why.

Mr Mot

Established Member
it's sorted it's self out now I'm in a new billing cycle

I moved to o2 last month, to simplicity for iPhone. It worked great at first but then had this glitch.

All is well now though, thanks folks :)

I presume yours will be the same Wendolene.


Standard Member
Same Problem here, cept i'm on 3.

My data allowances have been frozen( was working like you said ) for over 2 weeks now.

Hope it sorts itself out soon, i'm so anal when it comes to not knowing what i've used.

The latest video from AVForums

🎬 Across the Spider-Verse, Fast X, Covenant, Sisu, Changeling 4K, Lighthouse 4K, Quantumania 4K & TV
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom