1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Marantz SR4300 Want Bang!

Discussion in 'AV Receivers & Amplifiers' started by Ross007, Sep 15, 2004.

Tags:
  1. Ross007

    Ross007
    Active Member

    Joined:
    Feb 11, 2003
    Messages:
    655
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    28
    Location:
    Bristol
    Ratings:
    +31
    Watching TV the other night when the amp decided to crackle, pop and then emit a lightening type light from underneath. It then carried on as normal!

    I checked the amp and all the connections seem fine, I then did a speaker test and the Rear Left seems to have stopped working.

    Has this ever happend to anyone? If it has whats wrong?

    As usual this happened 18 months after I purchased it, so out of warranty. :thumbsdow
     
  2. Dfour

    Dfour
    Active Member

    Joined:
    Jan 19, 2004
    Messages:
    3,998
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    71
    Location:
    Bracknell
    Ratings:
    +85
    Looks like a new amp is on the cards im afraid. Have you got household insurance as you might be able to make a claim under it.
     
  3. Kazman

    Kazman
    Well-known Member

    Joined:
    Jan 14, 2004
    Messages:
    5,266
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Luton, Bedfordshire
    Ratings:
    +139
    Surge protectors, I keep telling ya, it sounds like a spike in the power.

    I have EVERYTHING going through a surge protection system, best way imho.
     

Share This Page

Loading...