1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Marantz 5200 has just exploded!

Discussion in 'AV Receivers & Amplifiers' started by Prav, Nov 16, 2002.

Tags:
  1. Prav

    Prav
    Active Member

    Joined:
    Jan 6, 2002
    Messages:
    96
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +4
    Just been watching Lord of the Rings in DTS (vol level -21db) and my amp switched off automatically during a loud sequence. When I switch it back on, sparks appear, a loud fizz and the amp switches off.

    I cannot beleive it! I only bought this amp in January, so it should be still under guarantee, plus because it's from Richer Sounds I have an extended warranty. However, I cannot find the receipt (its somewhere but may take ages to find).

    Has anyone experienced this before on this, or any amp?
     
  2. wilber

    wilber
    Active Member

    Joined:
    Sep 29, 2002
    Messages:
    1,970
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +30
    No experience re exploding amps but just to say that you should have no problem with RS 'cos they take your details at the time of purchase and log everything on their computer system.
     
  3. joshua_bond

    joshua_bond
    Active Member

    Joined:
    Jun 25, 2002
    Messages:
    342
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +16
    Prav,

    -21db is not that loud but I was wondering what kind (ohm, sens, Watts) of speakers u r using?
     
  4. Prav

    Prav
    Active Member

    Joined:
    Jan 6, 2002
    Messages:
    96
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +4
    Not sure about ohms etc - they are Mourdant Short speakers, centre and subwoofer and Eltax surrounds. All bought from Richers ironically enough. (They recommended them!) I wired them up properly and the unit had adequate ventilation.

    It first happened when I played Star Wars Ep 2 (it switched off when Anakin powers up his light sabre to kill the Sand people). And then it exploded when watching LOTR!

    I'm going to phone Richers to see what they can do.
     
  5. jimboyowen69

    jimboyowen69
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I also have a Marantz 5200 with a set of Kef eggs, and I have had mine up to -6 on said LOTR film and have had no such luck in producing sparks and the like.

    The bass at the start of the film is awesome though!!!

    Must just be a faulty amp mush.
     

Share This Page

Loading...