My DVD player has no RGB out!

Discussion in 'Blu-ray & DVD Players & Recorders' started by kerraig, Jan 28, 2003.

  1. kerraig

    kerraig
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Is this possible?

    It is a mid range Sony model bought in Hong Kong about 1 year ago. It has Component out and S-video out, but not RGB as far as I can see.

    I've connected it to my TV via s-video and the picture is shockingly bad. When looking at a plain black screen you get about 5 different layers of black.

    I think a new DVD player might be on the cards. Can anyone recommend a multiregion model that they've had good experiences with on a Panasonic PB50?
     
  2. LV426

    LV426
    Administrator Staff Member

    Joined:
    Jul 14, 2000
    Messages:
    12,819
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Somewhere in South Yorkshire
    Ratings:
    +5,027
    Quite likely for a Hong Kong spec machine.

    This should definitely not be the case. It suggests that there is a problem with either the player, the TV or the connection cable being used. My first suspect would be the TV, followed by the connection, followed by the DVD player. Try eliminating these things one by one:
    1: Try a friends' DVD player but use exactly the same connection. If solved, suggests the DVD player.
    2: Try using a different cable eg: if you aren't already, use a 'proper' SVideo cable (miniDIN>MiniDIN) connected to the socket on the front of the TV (if it has one) or via a Scart>SVideo+Phono adaptor plug if not. If solved, suggests the cable.

    If neither of these has an effect, the TV is suspect.
     
  3. kerraig

    kerraig
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    ok, cool, thanks for the advice.
     

Share This Page

Loading...