1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My amp sounds awful.....

Discussion in 'AV Receivers & Amplifiers' started by paulr, Apr 7, 2005.

  1. paulr

    paulr
    Active Member

    Joined:
    Jun 5, 2002
    Messages:
    1,151
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    North Lincs
    Ratings:
    +68
    Hi
    I recently bought a s/hand Marantz PM17 integrated amp,but tbh it sounds awful.Very bassy and boxed in.It was meant to replace my old Pioneer A400 but it sounds worse (by a long way).

    How do i know if there is a fault,or if a component is "on the way out".Do amps deteriorate?
     
  2. Dfour

    Dfour
    Active Member

    Joined:
    Jan 19, 2004
    Messages:
    3,992
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    71
    Location:
    Bracknell
    Ratings:
    +85
    Waht speakers/cd player and interconnects/speaker cable do you use? Any of these could also be making the difference. It could be the marantz is bringing out the worst in your setup that the old pioneer didnt.

    Have you got any other speakers you can borrow from a friend? Try them side by side and see.
     
  3. SKA.face

    SKA.face
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Is it worth rechecking the cables?Everything wired up correctly?The Pioneer A400 are quite bright,the Marantz will be far smoother,maybe just a bit of a sonic adjustment needed.
     
  4. paulr

    paulr
    Active Member

    Joined:
    Jun 5, 2002
    Messages:
    1,151
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    North Lincs
    Ratings:
    +68
    I've tried different sets of speakers.Yes,the A400 is quite bright,but after 12 years i like it.
    In comparison the Marantz is a much duller sound.
     

Share This Page

Loading...