1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My amp is humming (Triumph TA-250)

Discussion in 'AV Receivers & Amplifiers' started by Simon1987, Sep 16, 2005.

  1. Simon1987

    Simon1987
    Standard Member

    Joined:
    Sep 15, 2005
    Messages:
    34
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hi guys, I have a old amp it's a...

    Triumph TA-250

    And it makes a slight humming noise :S I think it has something to do with the power.

    It also has a grounding screw on the back, How can I ground it?

    also I feel that I get headaches when the amp is on... Is this possible? (Maybe its giving a hum on some freaquancy too high for my ears or something)
     
  2. gnikolaidis

    gnikolaidis
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Well, why dont you try to buy a new amp?
     
  3. Reiner

    Reiner
    Active Member

    Joined:
    Jul 16, 2000
    Messages:
    3,315
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    61
    Location:
    Germany
    Ratings:
    +13
    It's probably transformer hum. You could try, and I am not kidding you, do drip glue into the windings of the transformer.
    Make sure you disconnect the power before opening the unit.

    The grounding screw is for grounding turntables, not for grounding the amp.

    Sorry, no idea. (Anything is possible. ;) )
     

Share This Page

Loading...