Music sounding distorted

AudioJosh

Active Member
Hi,

I'm having a bit of a head scratcher here...

Some of my music is sounding a bit distorted when I play it through Apple Music or my CD player (Marantz CD6005). Not all tracks mind, just a select few.

However the same tracks sound fine through Spotify, which is a relief (sort of) as it rules out it being my speakers.

I reckon I've narrowed it down to the DAC I'm using, a Schiit Bifrost 2 (amazing DAC otherwise). When I plug the CD player directly to the amp theres no distortion on selected tracks. Still, it confuses me why certain tracks play fine through Spotify and not through Apple Music when I'm using the Macbook as the source into the DAC. I've tried a different Macbook with a different USB cable but still the same issue.

Anybody else experienced this kind of thing? Any tips?

I got the DAC second hand annoyingly. Hopefully I can get the warranty transferred if it is the DAC.
 
Last edited:

AudioJosh

Active Member
DAC into Yamaha A-S3000 with balanced cables. Macbook into DAC via USB. CD Player into DAC using Coax or Optical (same result).
 

Paul7777x

Distinguished Member
Or you could experiment with the headphone output from the Mac if not.
 

AudioJosh

Active Member
Thanks guys.

Yeh I tried another DAC and headphones and they worked fine.

After trying RCA out on the DAC and that sounding all fine I've narrowed it down to either the balanced output on the DAC or the balanced input on the amp being the culprit for the distorted sound. Seeing as I have two balanced inputs (BAL1 / BAL 2) on the A-S3000 and the same thing happens on both, I'm assuming that means the DAC is the issue.

I just need to find another balanced source to double check, but I annoyingly I just sold the only one I had.
 

ricof90

Active Member
Thanks guys.

Yeh I tried another DAC and headphones and they worked fine.

After trying RCA out on the DAC and that sounding all fine I've narrowed it down to either the balanced output on the DAC or the balanced input on the amp being the culprit for the distorted sound. Seeing as I have two balanced inputs (BAL1 / BAL 2) on the A-S3000 and the same thing happens on both, I'm assuming that means the DAC is the issue.

I just need to find another balanced source to double check, but I annoyingly I just sold the only one I had.
Do you have a friendly dealer or maybe local member who can help?
 

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom