MTU Failed (ICS Connection) tried everything!

Discussion in 'Xbox Forums' started by rudy_b, Sep 16, 2007.

  1. rudy_b

    rudy_b
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Dear ACForums,

    I've been around the net looking for solutions to my problem, and I stumbled across someone who had similar problems in a post on this forum. Similar, but not the same. I've tried everything I've found.

    My problem is this: My XBox 360 throws up a MTU error when I try to connect to live.

    My setup is this: I have a wireless receiver on my computer, as well as Ethernet ports. SO, I connect to the internet with my wireless receiver, and I connect my computer to my 360 via an Ethernet cord and a network bridge: http://bimmergeek.blogspot.com/2006/05/configuring-network-bridge-for-xbox.html

    Now, I am at a college campus, but I know that, in theory, this setup should work because there are a few rooms down the hall that have this exact setup. I've gotten past the IP and DNS errors that I initially had, but I couldn't figure out why I was getting this MTU error. The things that I heard were that the 360 needed a minimum MTU of 1364, or something like that. I came across this http://www.speedguide.net/downloads.php nifty tool, the SG TCP Optimizer. From there, I tested my MTU, and it came out to be 1472, well above the minimum requirement for Live.

    So, maybe my computer is blocking the packets? I'm running Peer Guardian 2 and Sunbelt Personal Firewall, but I tried to disable these programs to no avail. I also tried uninstalling these programs, also to no avail.

    Also, I came across this article:
    http://www.xboxlivetheguide.co.uk/XBoxLiveTheGuide3.php?title=MTU Failed

    I followed it's suggestions of changing the MTU of various different network connections. and STILL, NOTHING!

    I am so frustrated right now. Any help you could give me would be awesome.

    Thank you for your time,

    Rudy:thumbsup:
     

Share This Page

Loading...