1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mordaunt short sub connection problem

Discussion in 'Subwoofers' started by Omar78, Dec 23, 2003.

  1. Omar78

    Omar78
    Standard Member

    Joined:
    Dec 21, 2003
    Messages:
    46
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +2
    i purchased the mordaunt short premier speaker kit today.. along with a yam rxv340 receiver..

    i have connected all 5 speakers to the yam but when i came to connect the sub to the receiver with the supplied cable.. i got stuck. theres no where on the sub for me to connect the cable. its just a standard subwoofer cable.

    can someone please help me as i am a complete newbie..
     
  2. Grimley

    Grimley
    Active Member

    Joined:
    Sep 19, 2003
    Messages:
    854
    Products Owned:
    1
    Products Wanted:
    1
    Trophy Points:
    31
    Location:
    Deepest, Darkest Essex, so BEWARE!
    Ratings:
    +82
    If its a standard Sub cable it should be phono to phono cable so it should go in the line in or low level input connection on the sub.

    HTH
     
  3. Omar78

    Omar78
    Standard Member

    Joined:
    Dec 21, 2003
    Messages:
    46
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +2
    nah.. i need 1 phono to 2 phonos.. 1 phono from the amp.. then on the sub its 2 phonos left and right...

    iv just tried a standard cable and it worked.. but i think i need to get a better quality cable.. as the one iv tested it on was only £2 from maplins..

    iv just had another problem.. in the lotr2 the marsh scene.. when the dragon came.. the system just shut itself down.. when powered back on it said "check cables.." not sure what this means..
     
  4. clancol

    clancol
    Active Member

    Joined:
    Sep 6, 2003
    Messages:
    982
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Middlesbrough
    Ratings:
    +6
    no you only need two phonos on the sub when inputing stereo sounds. if you are using a suround sound arm rvx340 you will only need a phono - phono(LFE is mono) and plug it in to either left or right.

    Some sub makers recomend using a y spliter and running a phono to both the left and the right inputs but i can't see it making a difference in your system
     
  5. Omar78

    Omar78
    Standard Member

    Joined:
    Dec 21, 2003
    Messages:
    46
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +2
    oh right.. well im thinking of buying a small y slipper from maplins tomorrow.. its only £4 just in case :)
     

Share This Page

Loading...