• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Monitor Audio RSW12 Problem

baronm

Active Member
Hi All,

I'm having an issue with my Monitor Audio RSW12.

Most of the time it works perfectly, but occasionally, and seemingly more frequently, the audio is "sticking on" i.e. the film will move on to another scene but the sub will still be blasting out bass permanently (at the same frequency and high volume!), and can only be rectified by powering the sub on and off again.

The issue is across multiple sources (have had it on Blu-Ray and on HTPC). On Friday night for example, it had serious issues with the Blu-Ray of Big Trouble in Little China when it did it 4 times in the space of less than 10 minutes (from about 30 minutes into the film), and after the 4th I just left the sub turned off at the wall. We had watched The Warriors on Blu-Ray immediately before and didn't have a single issue, and I watched Jack Ryan: Shadow Recruit the following morning (film with lots of bass!) and had no issues at all.

Other items in my setup are listed in my sig.

Anybody had this problem or have any thoughts on what the cause (and solution!) is?
 

baronm

Active Member
Nobody?
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom