• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

MKV Playback ?

tmurphy

Established Member
Just updated to the new dashboard and testing everything working as it should.

I stream media from my PC using WMP, however I have always had to convert 720p MKV files to MP4 to play them back.

Don't know why but I just thought to test an unconverted MKV file. Added it to the MP library, and looked for it on the Xbox. Was expecting the usual, error unknown codec, but it started streaming and playing fine :)

HOWEVER...tried a movie file and it didn't play, then re-tried the previous two files and now they fail.... :(

Not sure what's going on, I don;t have any other transcoding services running on the PC, but will continue to check.

UPDATE : It's streaming MKV's again, however there's no functionality whilst playing, no details on time played/remaining, cannot fastforward.

What is idd that whilst playing an converted MP4 back the WMPNETWK service runs at 0% however when playing an MKV is rockets to 45% which says to be it's transcoding.

Can anyone else test, as I'm befuddled.

Tony
 
Last edited:

djstu_d

Established Member
hey,

after seeing your post, i thought i'd go take a look and your right, i've got a couple of .mkv files to play from my nas !!

only a couple are showing though & it seems a bit random...... one series folder is still not showing anything, another folder is showing 6 files out of 10 and will only play one of them ?!?!?

also got a couple of movies now showing up and am currently watching one.

wonder why it's so random ??

cheers.
 

tmurphy

Established Member
mine seems to like non AC3 MKV's but even then it's still hit and miss!
 

djstu_d

Established Member
mines a bit more random...

all files in 2 sep folders are x264, one folder shows nowt & the other shows some and will play only one ?!?!?

anyone else tried playing a .wmv ???
 

next010

Distinguished Member
Tried my Synology NAS and no difference at all though oddly enough some files showed but were crossed out as unplayable and other folders were empty.

WMP12 is not a great candidate to test with as it does not support MKV and if you've installed a plugin or hacked it to support MKV WMP will try to transcode the video to make it play so it's not really natively playing the video.

tmurphy use Serviio if you want to save yourself repackaging into MP4 it will real time transcode the video for you, also you can disable transcoding and see what happens.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom