Mission 70 AS Sub Woofer annoyingly turns on and off on it's own!

Discussion in 'Subwoofers' started by DaveH, Oct 2, 2001.

  1. DaveH

    DaveH
    Active Member

    Joined:
    Aug 1, 2000
    Messages:
    715
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Surbiton, Surrey
    Ratings:
    +22
    Dear all,

    My Mission woofer has a very annoying auto standby feature where it turns off after no LFE feed of 5 minutes.

    This is fine but, most of the time now it decides to turn itself on and off even when my receiver is turned off! e.g. I was sleeping last night and heard this loud crackle and the woofer turned itself on and off. The crackle continued.

    The weird thing is if I go round the back of the woofer, whilst it is doing this and place a finger over the standby L.E.D it will keep the woofer turned off.

    It is weird. Can I get it repaired so I do not have to turn it off at the mains to avoid it turning on and off all the time? Or is it something serious?

    Many thanks.

    Dave.
     
  2. DaveH

    DaveH
    Active Member

    Joined:
    Aug 1, 2000
    Messages:
    715
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Surbiton, Surrey
    Ratings:
    +22
    Sorry chaps,

    But the shops think I have gone mad when I mention this.

    I really do not know what to do about it.

    Anyone have any advice?

    Thanks.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice