1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

minipod speaker help please

Discussion in 'Home Cinema Speakers' started by noyce, Dec 24, 2003.

  1. noyce

    noyce
    Standard Member

    Joined:
    Aug 10, 2003
    Messages:
    179
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    England
    Ratings:
    +0
    I have just recieved my blueroom minipod 5.1 speakers but when i opened my subwoofer the power supply that has come with it is not a standard plug, it has two round prong like sockets which to me looks identical to those found on some electric shavers.

    Has anyone any ideas as i would really appreciate it.
     
  2. Warpaint

    Warpaint
    Active Member

    Joined:
    Jul 26, 2003
    Messages:
    589
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Edinburgh
    Ratings:
    +61
    If its a european model then it would come with this type of plug. Check that the voltage is 220 or 240 and if it is then all you need to do is cut off the two pin plug and fit a 13amp 3 pin plug. (Don't try a shaver adaptor as it probably has a 1 amp fuse and will blow) The cables will be coloured blue(neutral) and brown(live).
    Even better, if the mains cable is a plug in type (figure 8 or IEC 3pin) then just get a new cable.
     
  3. noyce

    noyce
    Standard Member

    Joined:
    Aug 10, 2003
    Messages:
    179
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    England
    Ratings:
    +0
    Thank you so much for the advice, you saved my christmas!
    Much appreciated.
     

Share This Page

Loading...