• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

messages on Mountain Lion

atki81

Active Member
I have enabled my accounts on message for mac but my messages don't show up on my MacBook. I read online that I would have delete all messages from that person on my iPhone for it to start working. Is this correct? If I turn my MBP on later should all messages sync with message?
 

leehardacre

Active Member
I could be wrong but I am under the assumption that in order for messages to appear on the mac, the sender must be sending the message to your iMessages e-mail. If they're sending to your phone number then they won't appear? Have you tried sending them a message from your mac?
 

hutch

Distinguished Member
You can also set iMessage on your phone to show your email address to the receiver rather than your phone number so the chances of you getting a reply which will show across your different devices increases.
 

hutch

Distinguished Member
Have to add that it is annoying that you cant add your phone number to your Mac though, hopefully it'll come.
 

Mudman

Active Member
Have to add that it is annoying that you cant add your phone number to your Mac though, hopefully it'll come.

I thought that was meant to be a part of ML, but I guess they might add it soon.

As said above every account (mac, macbook, ipad, iphone) all need the caller ID set to the same email address.

But if someone then send you an imessage to your phone no, it will only appear on your phone....
 

ferret1979

Active Member
I'm having a very strange issue with iMessage.

Basically any I send don't deliver, and I don't receive the ones that are sent to me.

I had this issue before, with messages beta, which was resolved by uninstalling it, but I can't do that now with Mountain Lion, plus I want to use it.

To get around the issue at the moment, I've had to disable it, does anyone have any ideas?
 

dwhite

Distinguished Member
Its an imessage issue across both OSX and iOS, the same behavior occurs for ipads.

As its already confirmed to being fixed in iOS 6, the assumption is that when that is released OSX will also be updated to ensure parity across all devices.
 
D

Deleted member 27989

Guest
I am running ios6 and it hasn't been fixed. There is no beta update for mountain lion yet in the developers area either.
 

Mudman

Active Member
I just downloaded iOS Beta 4, and now iMessages sent to my mobile phone number are suddenly appearing on my iMac and macbook air. This never happened before so is this a new addition added to the beta, or was my iMessages just decided to work properly?

Anybody elses iMessages sent to their mobile phone no appear on messages app on the computer?
 

CH_Peter

Well-known Member
Behaviour for me is exactly as would be expected. If it's sent to my Apple ID, it appears on all devices. If it's sent to my phone number, it only appears on my phone. Since I have an number of open conversations on the phone that were originally sent from my phone number and not my email (which i have subsequently set as the default), they are still going to/from the phone number. I guess if I deleted them and started over, they would come from the Apple ID.
 

Mudman

Active Member
Well it seems they are closer to making it unified then. Sent and received messages to my mobile phone no now appear immediately on all other devices.
 
D

Deleted member 27989

Guest
Hmm not working for me though.

Are you sure they are send to your mobile number?
 

Mudman

Active Member
Yep 100% sure.

I noticed it when my notification thing on the computer popped up telling me I had unread messages (despite the messages app being closed)

I have tested it by sending messages to people who only have my mobile phone number and all the messages are showing up on my iMac and Macbook Air and iPhone.

However if I send a message back from my computer or laptop then it goes via my email address and the person receiving the message gets a second thread start on their iPhone....
 

Mudman

Active Member
Although its nice to see my messages now on the messages app, its kind of annoying as I know I cant reply from the app, but have to reply from my iPhone.

Its very strange that you cant replicate this?!

I just sent a message to a mate who is not even saved in my address book (and who doesnt have any of my email addresses), the message immediately popped up on messages app and so did their reply
 
D

Deleted member 27989

Guest
Yes I have beta 4 installed.

They should link it such that when you reply on the Mac it actually gets send via iCloud to your iphone, and then the iphone forwards it in the background to the recipient. So no further action, but proper integration with the mobile carriers...
 

Mudman

Active Member
Maybe chance your caller ID on the iphone to your phone no and then disable and re-anable the imessage function and see if that works.

I didnt have my laptop on last night and this morning all the messages I got overnight popped up on my notification centre despite already being on my computer and having been read, so thats annoying..
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom