1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Megaworks 550 Satellite Speakers

Discussion in 'Home Cinema Speakers' started by Thermopyl, May 18, 2005.

  1. Thermopyl

    Thermopyl
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi
    I have hooked two of the satellite speakers for the above system to a standard HiFi Amp (Cambridge Audio). I now receive a horrible buz/drone noise...can anyone tell me why this is???
    Thankx
     
  2. Fotis_Greece

    Fotis_Greece
    Active Member

    Joined:
    Jan 6, 2006
    Messages:
    93
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +5
    Have you found any solution?
     
  3. Knyght_byte

    Knyght_byte
    Well-known Member

    Joined:
    Nov 4, 2004
    Messages:
    11,024
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Harrow, NW London
    Ratings:
    +599
    probably because the hifi amp is a proper amp for powering full size speakers, the megaworks speakers are not proper hifi, they are usually designed to only be fed from the matching subwoofers amplifier....

    at least im assuming you are talking about Creative Labs speakers?
     
  4. Thermopyl

    Thermopyl
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    yes..i had a ground loop problem. i bought a ground loop bypass on ebay and it worked a treat!
     
  5. Fotis_Greece

    Fotis_Greece
    Active Member

    Joined:
    Jan 6, 2006
    Messages:
    93
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +5
    ground loop bypass? Where do you connect this? Between the amlifier and each speaker?
     
  6. Thermopyl

    Thermopyl
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
  7. Fotis_Greece

    Fotis_Greece
    Active Member

    Joined:
    Jan 6, 2006
    Messages:
    93
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +5
    I am thinking of connecting the Megaworks sattelite speakers toa Denon 2106 amp. The Denon is 7x90W.
    How many W is your Cambridge audio amp? Is the sound better when using this amp than using the Megaworks amp in the subwoofer?
     

Share This Page

Loading...