Media Sharing Disabled

cunnas

Distinguished Member
Thought I would post this here as I got diddly squat from the Vista forum!

I use WMP11 on Vista Ultimate to share my media with my 360 - videos, photos, music.

A couple of weeks ago I fired up the 360 and it could not find the shared media. I went on the PC to see what was up and sharing had been disabled and I received an error message when I tried to turn it on - something like a windows component has been changed and sharing has been disabled. It gave me a few suggestions to try and get it sharing again but it didn't work.

It's not a huge issue as I found if I created a new account on the PC, WMP11 allowed sharing from that - so I just stick my media in that account now.

However, it is a bit of an inconvenience and I'm curious now!! Anyone had a similar thing happen?
 

cunnas

Distinguished Member
looks promising, will give it a go tonight, cheers mate.
 

nick501

Distinguished Member
Somebody posted exactly the same thing a few weeks back.

I tried all sorts of suggestions and non worked with the person in question

yeah, i think it may have been me.

i tried another go at fixing it last night to no avail.

in fact, things have got worse. bbc i player programs will not download to my pc now either.

i restored my computer to my last known good date (7th dec 08) and re-installed wmp11 and briefly the 360 did appear in the 'share to' box. then for no reason, my library disappeared again and wmp11 crashed when i attempted to share files.

tbh i dont stream that much to the 360, it's just bugging me that something is wrong and i cant find out what the problem is.

i will create a new account later and see if that works.
 

cunnas

Distinguished Member
didn't work for me...

>Open a command prompt (be sure to right-click and choose "Run as administrator" or you will receive a "system error 5 has occured. Access denied." error)
Type net stop winmgmt. If it warns you about other services stopping just type Y to continue.

Did this bit and got an error afterwards

>Delete the folder (choose the option that fits your Operating System)
- Vista 32Bit: %SystemRoot%\System32\WBEM\Repository and all its contents
- Vista 64Bit: %SystemRoot%\sysWOW64\WBEM\Repository and all its contents

Not even sure what folder it means here! I have no sysWOW64 folder from what I can see...
 

nick501

Distinguished Member
If it does work , follow that link I posted. Could sort the problem for you.

Slim

Created a new user account and after resetting my DRM folder on this new account all seems to be working ok :clap:

PC could see xbox, but, initially xbox could not see PC. turned off windows firewall and then xbox could see PC and play shared files. turned windows firewall back on and xbox could still stream files ok :confused:

Still no sure whats going on with the old account though.....
 

alexjholland85

Active Member
I had some serious problems, but all my answers came in the 'Services' function within 'Administrative Tools'.

There are a whole bunch of things that should be started, I quickly realised my 'Windows Media Player Network Sharing Service' needed to be started, but I got error messages when I tried to start it.

First I had to start a load including some of the networking functions, Plug and Play, SSDP Discovery Service etc, then my Windows Media sharing service started, and everything worked!

Sadly I just emptied my history folder so don't have the exact list of relevant services, but try googling it.
 

ftd2907

Standard Member
Fantastic!! Went into Services and found that my SSDP was disabled. Made this and UPnP automatic and started the services. Started Media Player Sharing and now works perfectly.
 

TorchMT360

Active Member
excellent same for me, SSDP was the culprit :smashin:
 

nictry

Distinguished Member
Just have to say a big thank you for this post as for some bizarre reason my Vista 64 machine suddenly stopped sharing with that stupid media settings disabled message and after an hour of searching around for a cure I found this thread :clap::clap::clap:
 

Sniper Ash6

Distinguished Member
Maybe some of this info should be added to the sticky to help others inthe future should they read the sticky first or find this thread via google?
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom