Quantcast

Media & File Server Bundle for the Foxsat HDR - Release 4,0 - PART 3

Status
Not open for further replies.

itm

Active Member
With this I can schedule HD recordings, use a splitter to cut the commercials if any, rejoin the now commercial free program, re-encode with Handbrake and put the file anywhere.

Completely stripping the DRM from broadcast TV is awesome. I will use it responsibility.
As a matter of interest. what application do you use to do the splitting?
 

zekepliskin

Novice Member
As a matter of interest. what application do you use to do the splitting?
Avidemux under Windows 7. Even if you cut out the breaks while the show is recording by manually stop/starting, you often find bits of them (say half a second) creep their way in. If you want a nice tidy commercial free thing, Avidemux can work with TS files to shave off the edges. When each part is ready, I use MKVmerge's "Append" function to create a complete contiguous file mux (usually strip the MP2 stream and keep only the main AC3 one) then have Handbrake run a 1080i50 to 1080p25 conversion (keeping H.264) at a decent bitrate. Other than a tiny video glitch between parts (a/v sync is maintained though, which is the important part) the whole thing is flawless and you can crunch down a 40-45 minute episode of ~3.5 GB to 1.14 GB and still retain excellent quality. Although I will say my fastest computer for video transcoding is about six years old so it takes an overnight non-turbo two pass to get the results I want, somewhere in the region of ten hours, so I only do this for stuff I really want to keep due to the effort involved.
 

wazzaworld

Standard Member
Hi,

Just wondering if anyone else has experienced their box freezing since the upgrade to 4.1.1?

My box has frozen 3 times since and did not have any such problems on the previous versions.

By freezing I mean unable to control via remote or any of the buttons on the front panel. Even the standby button does nothing. However, the current live channels continues to play out just fine.

I've not tried the web interface during a freeze or noted that it is recording anything either. Will try diagnose further.

I installed from being on v4.1.0 previously and from 4.0.8 before that. I did not reinstall the set top encryption patch after upgrade as I read that it survives the upgrade.
 

adrianf36

Well-known Member
wazzaworld said:
Hi,

Just wondering if anyone else has experienced their box freezing since the upgrade to 4.1.1?

My box has frozen 3 times since and did not have any such problems on the previous versions.
Are you using NASMount? If so have you read the documentation pages for it? I highly recommend the "Known Issues" section. If this is your problem it is easily avoided.
 

mrlong

Standard Member
I think that all of the benefits require you to be able to connect to the HDR via your home network (via web browser etc). So there is probably little you could benefit from just installing the firmware via USB and never connecting to your HDR via another computer. The new firmware basically opens up the access to the HDR as a Linux machine and all of the benefits are based on that (e.g. the channel renumber etc is done via a web page).

Dan
Thanks, Dan. Shame, but that was what I was expecting from everything I'd read.
 

gilesw

Standard Member
I've been using buzz player on my phone with mediatomb on the hdr and it works great, however I'd really like to plumb my hdr into plex. Annoyingly they've removed the ability to scan for a upnp share on mac os and even when I transfer the files to my htpc using ftp they don't play on the plex mobile client and the tv show scanner doesn't detect the names properly. All pretty fail. Wondering what everyone else does.. I tried smb too but the smb 2 compiled for the hdr doesn't work with the new non samba smb implementation on mountain lion. At the moment I'm thinking I may just have to transfer the files off the hdr, transcode them or put them into a container that plex likes, and then rename them so it can scan.
 

illingworth22

Active Member
Hi,

Just wondering if anyone else has experienced their box freezing since the upgrade to 4.1.1?

My box has frozen 3 times since and did not have any such problems on the previous versions.

By freezing I mean unable to control via remote or any of the buttons on the front panel. Even the standby button does nothing. However, the current live channels continues to play out just fine.

I've not tried the web interface during a freeze or noted that it is recording anything either. Will try diagnose further.

I installed from being on v4.1.0 previously and from 4.0.8 before that. I did not reinstall the set top encryption patch after upgrade as I read that it survives the upgrade.
I to am experiencing a Box Freeze after upgrading to 4.1.1 but I am not using anything different from before!

What is NAS Mount? I have also dicovered that I cant log onto the Humax via the web browser now either and the Humax seems to take ages to retrieve programm info!

Now I can access the box via web browser but it is running very slow! I have just re set up the record it is taking ages for the mo register....... No NASMount install on my box!

I have also notice every time I press the "Guide" button the box has to retrieve program information!
 
Last edited:

wazzaworld

Standard Member
Are you using NASMount? If so have you read the documentation pages for it? I highly recommend the "Known Issues" section. If this is your problem it is easily avoided.
Ah yes - thanks for that. It does sound like it would be the issue as I did just recently enable the NASMount feature.

Not had an issue of late as I haven't actively used the mount. Am now keeping an eye on the separate NASMount thread for info and potential fix. Can see 1.0.1 update is out but it doesn't look to fix this one.
 

Chippy99

Well-known Member
Can I just echo a comment from a few posts back, saying a HUGE thanks to Raydon for all of this.

I rarely post here because his software is simple to install, simple to use and basically just works! And the functionality provided is for me, totally brilliant.

Raydon, thank you!
 

illingworth22

Active Member
Help the Wife is driving me Mad!

I am experiencing a Box Freeze after upgrading to 4.1.1 but I am not using or have not added anything different.

Now I can access the box via web browser but it is running very slow! I have just re set up the record it is taking ages for them register....... I haven't installed NASMount on my box!

I have also notice every time I press the "Guide" button the box has to retrieve program information which is also very slow.

Any suggestions (apart from Shooting her!) ?
 
Last edited:

raydon

Well-known Member
Help the Wife is driving me Mad!

I am experiencing a Box Freeze after upgrading to 4.1.1 but I am not using or have not added anything different.
Do you mean box freeze as in total lockup where you have to reboot to get things working again ? v4.1.1 had only a very minor change to one line in a config file compared with v4.1.0. And this only affected the way the box stopped the ethernet interface on shutdown or reboot. Nothing to do with normal operation.
Now I can access the box via web browser but it is running very slow! I have just re set up the record it is taking ages for them register....... I haven't installed NASMount on my box!
So it's not frozen then ??
I have also notice every time I press the "Guide" button the box has to retrieve program information which is also very slow.
Any suggestions (apart from Shooting her!) ?
This is normal when pressing the Guide button and it will always take around 30 seconds plus to refresh. If you dont want to wait then access the EPG using the Schedule then Red buttons.
And if you are in any doubt about whether the CFW is causing your problems you can always temporarily reflash the standard firmware and make a comparison.
 

raydon

Well-known Member
Can I just echo a comment from a few posts back, saying a HUGE thanks to Raydon for all of this.

I rarely post here because his software is simple to install, simple to use and basically just works! And the functionality provided is for me, totally brilliant.

Raydon, thank you!
Thank you Chippy99 for your kind remarks. However, I must point out that I am not the only developer on this project and cannot take all the credit for it. Thanks must also go to adrianf36, Partridge, REPASSAC, and David500 for their work on the web interface and associated plug-ins and documentation, and to several other contributors of packages which all go to make the HDR a great PVR. Thanks guys :thumbsup:
 

illingworth22

Active Member
Do you mean box freeze as in total lockup where you have to reboot to get things working again ? v4.1.1 had only a very minor change to one line in a config file compared with v4.1.0. And this only affected the way the box stopped the ethernet interface on shutdown or reboot. Nothing to do with normal operation.

So it's not frozen then ??

This is normal when pressing the Guide button and it will always take around 30 seconds plus to refresh. If you dont want to wait then access the EPG using the Schedule then Red buttons.
And if you are in any doubt about whether the CFW is causing your problems you can always temporarily reflash the standard firmware and make a comparison.
Raydon, thanks for your reply. Yes it has completley frozen.

At present it is stuck on BBC 2 NI and the banner is on the screen BBC 2 NI the clock in the bottom right says 11.58 23/02/2013 and the Program showing was Map Man. I just logged on to the Humax with IE and I cabn see the Front page, when I go to the remote control and try to change the chanel I can press the first button then it also freezes.

So I have now just switched off the Box with the back switch and turned back on again and it is working again....... for now.

Do you think it could be the Hard Drive that is causing the problem? I have recently had to re format due to all the recordings being lost!

How do I revert or reflash back to the standard firmware, via Menu...... Setup - Factory Reset?
 
Last edited:

raydon

Well-known Member
Raydon, thanks for your reply. Yes it has completley frozen.

At present it is stuck on BBC 2 NI and the banner is on the screen BBC 2 NI the clock in the bottom right says 11.58 23/02/2013 and the Program showing was Map Man. I just logged on to the Humax with IE and I cabn see the Front page, when I go to the remote control and try to change the chanel I can press the first button then it also freezes.

So I have now just switched off the Box with the back switch and turned back on again and it is working again....... for now.

How do I revert or reflash back to the standard firmware, via Menu...... Setup - Factory Reset?
No, you need to download the standard hdf from HERE , put it on a USB stick and reflash with that.
 

illingworth22

Active Member
No, you need to download the standard hdf from HERE , put it on a USB stick and reflash with that.
I just wonder if it has a tithing to do with the Hard Drive! I re formatted both Hard Drives recently and left the Video as big as poss and the Music as small as possible!

I am going to check box number 2 this morning to see if it has the same problem, as its display is also stuck on the custom 4.1.1 screen (it's just a pain to check this cos it's in a box room)

EDIT-----------
I have just re flashed the box with the original firmware and it is still doing exactly the same. When I reflas with the Humax Firmware are all traces of the custom firmare removed?

Anyway Box No 2 seems to be OK for now!

Any suggestions? Could it be the Hard Drive causing the Big Freeze?
 
Last edited:

raydon

Well-known Member
I just wonder if it has anything to do with the Hard Drive! I re formatted both Hard Drives recently and left the Video as big as poss and the Music as small as possible!
Well, all of the applications you install after flashing with CFW reside in a folder on the Music partition so you should provide space for that. I reckon around 5GB should be more than ample if your not storing music or photos. You must have had to re-install everything after you did the partition resize anyway. Did the problems start immediately after that ?
I have just reflashed the box with the original firmware and it is still doing exactly the same. When I reflash with the Humax Firmware are all traces of the custom firmare removed?
The custom firmware is completely replaced by the standard firmware, but the software applications (things like the web server and ftp server) still remain in the folder on the Music partition. However, they can no longer be accessed and just lie dormant. If you now re-install the custom firmware all of the applications you installed previously will be active again.
Any suggestions? Could it be the Hard Drive causing the Big Freeze?
Yes, it's possible that your HDD could be failing. Try running the 'fix-disk' utility as outlined here.
 

grahamlthompson

Distinguished Member
The Foxsat-hdr will boot with the hard drive disconnected. Easy enough to disconnect the drive and see if the boot sequence completes.
 

Dbl-trouble

Novice Member
Well, all of the applications you install after flashing with CFW reside in a folder on the Music partition so you should provide space for that. I reckon around 5GB should be more than ample if your not storing music or photos.
I'm running with a 1GB Music partition, and it seems to work fine.

cheers, Martin
 

raydon

Well-known Member
I'm running with a 1GB Music partition, and it seems to work fine.

cheers, Martin
Seems a bit meagre but as long as it works then fine. I can't say offhand exactly what is needed as I have a lot of development stuff on my own Music partition which takes up a fair bit of space.
 

zekepliskin

Novice Member
Seems a bit meagre but as long as it works then fine. I can't say offhand exactly what is needed as I have a lot of development stuff on my own Music partition which takes up a fair bit of space.
Yeah I can confirm as long as you keep a few hundred megabytes free (maybe less, I'd rather be safe though) on the Music partition the custom firmware will run as it should. My Music partition is a mere 0.6GB (I shrunk it using a Gparted Live USB when I had the Foxsat apart) and I have no problems, so... :D

Out of curiousity, why are all the custom resources on the music partition? Is it because it's the part of the HDD least likely to corrupt/be formatted/be tampered with by the original Humax parts of the firmware or something like that?
 

raydon

Well-known Member
Out of curiousity, why are all the custom resources on the music partition? Is it because it's the part of the HDD least likely to corrupt/be formatted/be tampered with by the original Humax parts of the firmware or something like that?
Most people only use their HDR for video recordings, so the smaller and little used, (or not used at all) Music partition was the logical choice for custom apps, leaving the full Video partition for recordings.
 

zekepliskin

Novice Member
Most people only use their HDR for video recordings, so the smaller and little used, (or not used at all) Music partition was the logical choice for custom apps, leaving the full Video partition for recordings.
Very true. That's the exact reason I shrunk mine down. There's a few dozen tracks on there as a sort of token concession to the music player feature but that's it.
 

TJT1

Member
I recently had a bit of finger trouble whilst deleting multiple recordings using the CF accessed with my lappy. The recordings were in a series folder. What I did was inadvertently start to delete a second recording before the first had reported as fully deleted. This left one of the files associated with the first recording, the .hmt file if I remember correctly, thus left the series folder in place with no aparent method of deleting it from the CF. I recovered the situation by accessing the hummy Video folder from a mapped drive on my lappy and deleting the errant file and the series folder from there.

The moral of this story? Wait until one deletion is complete before initiating a second.

Suggestion for Raydon pretty please. Is there a possibility of a mod to the CF to prevent the user initiating a second delete before the previous one has completed? Or better still, allow the user to input multiple deletes as quickly as they want/can, but queue them for deletion as and when the hummy has deleted the previous file set?
Or even a recursive delete on a series folder contents, so that the user only has to 'delete' the folder, and the CF deletes the files within correctly?
It would alo be useful to include a "Deleting Files" type popup whilst it was working on the deletions in any case.
 

grahamlthompson

Distinguished Member
Use the webif remote and file managers edit mode to select multiple files/folders for deletion. One push of red will delete the lot one after the other. If you try putting the box in sby whilst it's processing multiple deletes the box will shut down after all the deletes are completed.
 

psp

Standard Member
I've installed Raydon's bundle and everything seems to work. Problem is getting Chrome on my Nexus 7 to use the vlc plugin.

I've verified that I can run video from the Foxsat in Chrome on various Windows laptops, but the Chrome for Android on the Nexus stubbornly refuses - saying that it does not support the plugin. Is that true?
 

TJT1

Member
Thanks for the idea GLT. I'll have a go at that so that'l fix my problem when I do deleting again. I still think that the CF should probably have some sort of trap in it to prevent what I did from happening to other impatient souls
 

REPASSAC

Well-known Member
raydon - I guess that Logi is about to split this thread again. Hopefully he will copy post 1 across. Thanks in advance Logi.
 
Status
Not open for further replies.

Trending threads

Latest News

Kef Reference Series gets new finish and additional model
  • By Andy Bassett
  • Published
Naim announces native Qobuz support for its streaming hardware
  • By Andy Bassett
  • Published
Disney+ generates $100M in mobile app spending since launch
  • By Andy Bassett
  • Published
Bang & Olufsen announces Beoplay E8 3rd generation wireless earphones
  • By Andy Bassett
  • Published
Top Bottom