Media Center wont start on Vista - "Media Center has stopped working"

Discussion in 'Microsoft Windows' started by mark.carline, Aug 31, 2007.

  1. mark.carline

    mark.carline
    Active Member

    Joined:
    Jan 15, 2004
    Messages:
    2,132
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Chester, Cheshire
    Ratings:
    +121
    I have just rebooted Vista and for some reason when I now try and start Media Center i get a message saying "Media Center has stopped working". When I click on view problem details it also tells me:

    Description:
    Stopped working

    Problem signature:
    Problem Event Name: CLR20r3
    Problem Signature 01: ehshell.exe
    Problem Signature 02: 6.0.6000.16386
    Problem Signature 03: 4549b55e
    Problem Signature 04: mscorlib
    Problem Signature 05: 2.0.0.0
    Problem Signature 06: 4536f11f
    Problem Signature 07: 3318
    Problem Signature 08: 15a
    Problem Signature 09: System.UnauthorizedAccess
    OS Version: 6.0.6000.2.0.0.256.1
    Locale ID: 2057

    I have also noticed that there is a service called "Windows Media Center Service Launcher" which isnt started. When I try and restart it it just stops after a couple of seconds.

    I have checked the media center event log and its full of messages like "The recording schedule has been corrupted and was automatically deleted on 08/31/2007 07:05:37. You may need to reschedule your recordings." I have done some searching and the only thing I have found that seems to relate to this message is this link:

    http://www.msfn.org/board/index.php?showtopic=103511

    I have tried some of the advice in this thred but the event log was then full of messages like "unable to find C:\Documents and Settings\All Users\Application Data\Microsoft\eHome\EPG\tracehelper\DefaultDomain-VISTAPC$.xml" so I restored the EPG folder and tried to just delete the massive .sdf files.

    Does anyone have any ideas or know of a way to completely reset Vista Media Center back to default settings ?
     
  2. Synchro

    Synchro
    Well-known Member

    Joined:
    Nov 14, 2004
    Messages:
    6,059
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Chester
    Ratings:
    +1,573
    Afraid not. You say a reboot started all this? What made you reboot? Were you installing/removing/tweaking something?
     
  3. mark.carline

    mark.carline
    Active Member

    Joined:
    Jan 15, 2004
    Messages:
    2,132
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Chester, Cheshire
    Ratings:
    +121
    yes sorry forgot to mention :( I had just applied this weeks windows updates, all seem to be unrelated to MCE but to rule these out I have been down the route of uninstalling them but no luck.

    I have seen a couple of utilities that seem to be able to "reset" media centre back to default but they dont seem to be supported on Vista:

    http://www.salloway.org.uk/MediaCenter/util/index.htm

    I am convinced that there is some corrupt data (maybe guide data) at fault here and I just need to either delete a file or set some kind of flag for media centre to reinitalize its settings.

    Any ideas ?
     
  4. mark.carline

    mark.carline
    Active Member

    Joined:
    Jan 15, 2004
    Messages:
    2,132
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Chester, Cheshire
    Ratings:
    +121
  5. HexElffilter

    HexElffilter
    Standard Member

    Joined:
    Nov 30, 2006
    Messages:
    49
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +7
    I've had strange things happen to me after updating vista.

    Recently I updated vista and IE completely stopped working and kept crashing.
    I did a system restore to just before I installed the updates, and after a reboot everything was fine again.
     
  6. perkyparker

    perkyparker
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i would try turning off UAC in "user accounts" in the control panel..
    good luck!
     
  7. mark.carline

    mark.carline
    Active Member

    Joined:
    Jan 15, 2004
    Messages:
    2,132
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Chester, Cheshire
    Ratings:
    +121
    ok i'll give it a go - i dont hold much hope.

    I think i'll be reinstalling this weekend :mad:

    WAF is at an all time low !
     
  8. jakelv7500

    jakelv7500
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi folks;

    I started getting this error after installing patch KB938979, ironically called a "reliability and compatibility" patch. I fixed it by navigating to folder "C:\ProgramData\Microsoft\eHome" and granting Full Control access the folder, its subfolders and files, to the Everyone security group. Hope this helps.....

    JAKE
     
  9. mark.carline

    mark.carline
    Active Member

    Joined:
    Jan 15, 2004
    Messages:
    2,132
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Chester, Cheshire
    Ratings:
    +121
    Reinstall fixed it !
     
  10. Synchro

    Synchro
    Well-known Member

    Joined:
    Nov 14, 2004
    Messages:
    6,059
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Chester
    Ratings:
    +1,573
    A shame when it comes down to that, but with good backups, it shouldn't be too much hassle.
     
  11. mark.carline

    mark.carline
    Active Member

    Joined:
    Jan 15, 2004
    Messages:
    2,132
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Chester, Cheshire
    Ratings:
    +121
    Yep - Whole reinstall done with data all copied back on in 1/2 a day.

    It even fixed the blank screen 10 minute bug and it seems to be running 10x faster
    :thumbsup:
     

Share This Page

Loading...