Mede8er MED500X or Popcorn Hour A-200

duffy78

Active Member
I'm thinking about getting a new media streamer and have narrowed it down to these two.

They are both pretty similar on price, think there's about £30 difference between the two.

Does anyone have any comments on how they compare?
 

Member 351202

Novice Member
My wife says the mede8er is loads better than the A200.
That is as technical as she gets but i made her use the A200 for a week and in the end she stopped using it and went without desperate housewives and true blood for a bit :)
 

skinnywhippet

Active Member
well i can confirm that with the latest Mederer GUI it stutters like hell via hard drive when playing back full BD iso's, no such problem with the A200. The earlier firmware (2.1) for The Mederer works fine tho so must be firmware related and not hardware.
 
well i can confirm that with the latest Mederer GUI it stutters like hell via hard drive when playing back full BD iso's, no such problem with the A200. The earlier firmware (2.1) for The Mederer works fine tho so must be firmware related and not hardware.

Really? I've not had any such problems, either on f/w 3.04 or V4BETA4, with my Mede8er.
 

djglenn1337

Standard Member
My wife says the mede8er is loads better than the A200.
That is as technical as she gets but i made her use the A200 for a week and in the end she stopped using it and went without desperate housewives and true blood for a bit :)

True blood is strange, but very compelling to keep watching.
 

duffy78

Active Member
what happens with the players when you feed them dts-ma, can they both pass it through as a bitstream? Can you get them to downmix it? Can they take the legacy dts track from it and bitstream that?
 

skinnywhippet

Active Member
are you playing back full BD ISO's of 40+ gig?

I set up my mates Mederer with a 4 drive usb caddy packed with bluray isos, it stuttered with a lot of the isos, particularly the bigger isos. I trawled through the Mederer forums and it was suggested there that something was broken after version 2 firmware with respect to BDISO's. Someone stated that going back to version 2 worked fine. Sure enough, I reverted to v2.1 (or 2.2 - cant remember) and they all work fine now....

cheers,

Neil

note didnt try the V4BETA4 right enough
 

The latest video from AVForums

Podcast: Philips TV Launch Event, Soundbar vs AVR, Samsung EzCAL and more...
Top Bottom