MCE showing black in fullscreen

Desmo

Distinguished Member
Hi people, I've done a search and tried a few different things I've come across but can't seem to solve this problem.

MCE works fine in when windowed but when I lmake it fullscreen it just goes black with a slight flicker to the mouse pointer. If I hit the "Windows" key so XP takes focus, I can see MCE in the background running fullscreen perfectly. As soon as I click on MCE again it goes black.

This is a homebuild system from a few bits and pieces I had laying around. Using a Saphire Radeon 9600.

Any ideas?
 

StephenR

Standard Member
Bit of a long shot, but I had a similar problem with my Media Center and it was because my TV would only accept a 50Hz signal. I had set the desktop resolution to 50Hz, but when Media Center goes full screen it forces 60Hz unless you add the EnableRefreshRateChange registry entry (do a search to find out about this). Once I had added the registry entry I no longer got a black screen when starting Media Center. Hope this helps.
 
A

applevenus

Guest
change your graphics resolution to a lower resolution - that might help
 

Rickyj at Kalibrate

Distinguished Member
AVForums Sponsor
As stephenR says, it is probably to do with the refresh rate, but if you are using a custom resolution, you may also need to create a device driver rather than using the plug and play driver, as I found with my HS20.

See this thread, for some more info;

http://www.avforums.com/forums/showthread.php?t=278385&page=2

Ricky
 

Desmo

Distinguished Member
Well this is strange :/ After doing some more forum searching I came across an Australian MCE forum and found on there something to do with changing my TV output from PAL to NTSC. I did this and all is working fine. But then later on I changed it back to PAL again and it seems to still work. A bit confused about it all but it's working now.

Only thing I get now is a real slight flicker on the TV. I think it's just to do with the fact I'm using S-VHS and a CRT but will do a bit more searching to see if I can improve on that.

Thanks all for your replies :)
 

Desmo

Distinguished Member
Maybe problem isn't solved :/

MCE just will not display in fullscreen whilst set to PAL. But it will work when set to NTSC. Only problem is I ge a slight screen flicker with NTSC which is a bit offputting.

I've tried the RefreshRateChange reg edit but still no joy. I've tried to get every app I can to hold the refresh rate at either 50 or 75 whilst in PAL but nothing seems to work.
 

Desmo

Distinguished Member
Wohooo, think I've got it solved once and for all :D

After reading another thread about a different problem, it gave me an idea. I went into the MCE setup section and changed it from TV to Flat Panel and S-Video to DVI/VGA. It seems to have done the trick whatever it does :D

I can now use whatever res and refresh rate I choose, along with using PAL and not NTSC.
 

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom