1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Marantz SR4200 clicking noise

Discussion in 'AV Receivers & Amplifiers' started by DpM, Sep 17, 2003.

Tags:
  1. DpM

    DpM
    Well-known Member

    Joined:
    Jul 15, 2003
    Messages:
    4,265
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    High Wycombe, UK
    Ratings:
    +804
    I have a Marantz SR4200 which like to produce a loud clicking noise from the rear speakers sometimes when the amp is in DTS mode, by turning the amp off and on again it stopps happening. This also tends to happen mostly when I have paused a film (for a loo/drink break) and then started playing it again. Also in pro logic 2 (on the video and tv input, havent noticed it on the cd input) and dolby digital (again on the dvd input) I somtimes get a click on random speakers at random times, has anyone else come across this problem with Marantz SR range?

    Any ideas what the problem could be?
    I cant remeber where I bought it from (it was around 2 years ago, blimey that went quick!), so I have looked on the Marantz site for a contact numer or e-mail and the only thing i can find is a postal address for the Netherlands for european customers! Anyone got a contact in the UK? Or maybe someone could recomend a company that would fix the problem.

    Could electrical wires/extention leads being too close to the amp or speaker cable effect it the sound if so roughly how close would too close be?

    Lots of questions and an anoying problem, especialy when watching a film with a great DTS track. :thumbsdow


    Any question answers or advice would be great

    Thanks

    DpM
     
  2. Mylo

    Mylo
    Well-known Member

    Joined:
    Mar 13, 2003
    Messages:
    5,541
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Ratings:
    +372
    Try this. Nice and local.

    Marantz UK Ltd
    Kingsbridge House,Padbury Oaks 575-583, Bath Rd Longford
    West Drayton Middlesex
    UB7 0EH

    Tel: 01753 680868
     
  3. MonkeyDonkey

    MonkeyDonkey
    Standard Member

    Joined:
    May 9, 2002
    Messages:
    401
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    UK
    Ratings:
    +1
    The DTS clicking is a well known problem with this amp.

    A search on these forums for sr4200 clicking should yield all the answers you want.

    I chose not to bother trying to get mine fixed, partly because I know about the problem and therefore make sure I stop the film rather than pausing when in DTS mode and partly because I didn't want to be without an amp for god knows how long.

    Perhaps if you have plans to sell it on in the future it may be worth it, but I have a 50% buy back guarante from RS so once the 3yrs is up I'll pop along and pick up something new with £100 knocked off.
     
  4. Ricky27

    Ricky27
    Active Member

    Joined:
    Feb 8, 2002
    Messages:
    1,855
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Norwich
    Ratings:
    +198
    Hi, sounds like you've got one of the duff amps Marantz let out before they found out that a component wasnt compatible with the UK power supply.
    Have you noticed on menus or when you change chapters that there is a long delay before the sound kicks in again? This was another side effect of the faulty units.

    I had a 5200 with the same problem although i lived with it cos i never got the clicking noise on DTS and was so impressed with the sound etc.

    I upgraded to a 5300 and all the problems have been sorted.
    The fixed units have a little round greeen sticker on the serial number sticker and on the box.
     

Share This Page

Loading...