Marantz nr1711 Auto switching back to hdmi 1 input

RichieHH

Novice Member
I've a Deutsche Telekom magenta box on the cbl/sat input. A ps4 on the DVD input. The game input we plug a PC into occasionally. Everything's working kind of fine. I had to increase the source signal on the cbl input by 2db though. The issue I have is that with both ps4 and telekom box on, the nr1711 auto switches back to the cbl input a few seconds after I've selected dvd to turn on the ps4 display. With the cbl source(telekom) off, all good. This is with hdmi control on.

Before I go any further, is there any obvious setting I've overlooked that causes my receiver to insist I watch Telekom box when it's on? There are no cec/hdmi options on the magenta box that I can see where it might be telling the avr to "switch back to me".

Regards.
 

dante01

Distinguished Member
I'd suggest it is HDMI CEC (Control) that is responsible for the behaviour you are experiencing. Turn it off on all the source devices or at least on whatever device is connected the HDMI1.

What is the HDMI-CEC function on my Media Receiver/MagentaTV Box?​

Under the menu item "TV" you can activate the HDMI-CEC function to turn your TV on and off with the remote control of the MagentaTV receiver or MagentaTV Box.
The function is supported by the media receivers 401, 201, 601 Sat as well as the MagentaTV Box and MagentaTV Box Play.

To activate the "Control TV" function in the menu of your receiver:
Settings > Other devices > Televisions

You may also have to activate the function on your TV. Depending on the TV manufacturer, the HDMI-CEC function has different designations:
  • EasyLink at Philips
  • Simplink at LG
  • DigitalLinkHDat Loewe
  • Viera Link at Panasonic
  • Anynet+ at Samsung
  • Bravia Sync at Sony
  • Digi-Link at Grundig

 

RichieHH

Novice Member
Ok, thanks. I'll need to dig deeper as I can find no such setting. Easiest is to just turn off hdmi control for now . It all seems a bit hit and miss.
 

dante01

Distinguished Member
You could use one of these if there's not an actual setting on the box that would allow you to turn HDMI CEC off:

Amazon product

It will prevent HDMI CEC from being able yo communicate with other devices connected to it.
 

RichieHH

Novice Member
Thanks again. I found the setting... Was only discoverable through the search interface. Disabled the smart cec option and the auto switchover issue was solved. The downside being of course when the gf turns off the Telekom box or it sleeps, the TV and avr remain on depending on their idle settings. I think here best is to leave cec enabled and simply turn off the Telekom box and then turn TV back on when I want to use the console.

Thanks again for your help.
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom