Marantz NR1604 stuck in an "Update retry" Boot Loop

StuL

Standard Member
Hi
I have just recently purchased a NR1604 which I was very pleased with and was working absolutely fine.

Unfortunately I made the mistake of trying to update the software via LAN cable without first checking if it was actually connecting to the internet, I had not previously tried any of the online functionality of the receiver.

For some reason because the LAN cable was connected to my Router and had previously been in the back of my PC which is connected to the Internet all the time I just thought it would just connect automatically but it tries to update and then comes up with "connection failed" and then "Update retry"

I have looked on the internet for any information in regards to this issue and I also have a copy of the User Manual so have followed the factory reset procedure which didn't work and I tried it several times.

My Guess is i should have configured the network settings within the AV receiver before trying to update to make sure it was actually connected to the Internet but I have to say it never crossed my mind that I would need to do so.

I have even been on my Router manager to try to find out if there is anything i might be able to do from that end of things in order to allow the receiver access to the internet but i have no idea which settings to be messing around with or even what the correct IP address is for the receiver

I think I have probably lobotomised my week old AV receiver

The Only thing i don't understand is why if it cant connect to the internet, why wont it reboot back into normal operating mode this to me seems like a MASSIVE oversite on behalf of Marantz.

so i think I'm clutching at straws here... but if anyone can give me any advice of anything else I can try I would be most grateful, especially if you might know what setting I should be looking at on my BT home hub manager perhaps to allow access to the internet so I can complete the update.

Thanks in Advance
Stuart
 
D

Deleted member 39241

Guest
Have you tried resetting the microprocessor - page 157 of the manual.
 
D

Deleted member 39241

Guest
If you completely remove the power cord from it, then plug it back in, does it go straight to the updating cycle? Can you intercept with a reset once you restore power, before it goes back to attempting the update?
 

wiz

Distinguished Member
f you completely remove the power cord from it, then plug it back in


..and wait ten mins before putting back in.

If that does not work do a firmware restore
 
D

Deleted member 39241

Guest
..and wait ten mins before putting back in.
I always thought that was a myth. If the electronics are unpowered, how do they know when 10 minutes have passed?
 

StuL

Standard Member
..and wait ten mins before putting back in.

If that does not work do a firmware restore
Thank you for the suggestion i will give that a try and report back
in regards to the firmware restore how would I do that on my particular model ? as according to information available to the Marantz website this model is not able to be firmware updated by USB
if it was i would of done that already by downloading the latest firmware then updating by Memory stick
 

StuL

Standard Member
HI Guys
thank you very much for your assistance I'm happy to say that i have the NR1604 back on the road again.

there were two problems the 1st is that the Factory reset procedure in the manual for this model NR1604 is WRONG i needed to follow the reset procedure for the NR1605 which was shown on a page on the Marantz support website i had to press the "Zone 2 source" + "Internet radio" buttons" together as i switch the unit on, then i heard an audible Beep which reset the software and i was able to use the normal functions again.

in the manual for the NR1604 it says to press the M Dax Button and the Zone 2 Source Button Together as you switch the Unit on which did nothing no matter how many times i tried it.

the second point was that the Marantz update page for the the NR1604 is no longer available so there was literally nothing for it to connect to hence why it kept failing to update.
I had chance to check the internet settings and I was definitely connected to the Internet even though I thought I wasn't as i listened to some Internet radio.
so thanks again for your assistance.
 

The latest video from AVForums

Bowers PI7 wireless in-ear headphones review coming soon to AVForums
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom