Marantz CR603 stuck in firmware upgrade loop

Mike B

Standard Member
Hi all,

New here but I've been a long time lurker.

I've got a new Marantz CR603 and I'm having some problems with the firmware upgrade. I get past the "Authorising" stage but as the unit is "Updating" it starts at 13min and counts down to 1min then loops back to 3min and starts again (3,2,1,3,2,1,3,2,1). This is on the screen with NET(IMG) at the bottom.

I've let this run overnight without any success. If I power-cycle the unit it's seems fine. Then after a few minutes it gives me the "Upgrade Available" notification. I try it again and I get the same.

I've tried the Vol-up + Vol-down Initialise option without any luck. I also notice that it doesn't seem to download anything before the update (unless the file is very small). The unit is connected directly to my ADSL modem/router and I've also tried the update on another network.

Any help appreciated.

Mike
 

samini

Novice Member
I just got the CR603 yesterday... it took a bit of time to update the firmware, but didn't get stuck. The bit which took the longest was the net (img)... got there in the end though. How is it connected to the internet, direct in to the router or do you use powerline/bridge setup?

When its on you will be chuffed, mines all set up now with AirPlay, Napster etc... brilliant!
 

Mike B

Standard Member
It's connected via an ethernet cable directly to the router/modem.

Though by the time it gets to the upgrading part there is no network activity anyway (been keeping an eye on the firewall logs). I'd been warned that it could take 30-60 minutes but 8+ hours seems a little too long. Particularly given the fluctuating time-remaining countdown!
 

samini

Novice Member
Very strange that Mike, sometimes people have reported issues because they are connecting to the internet via power adapters on the wall plugs!

Try resetting the router, that usually fixes things for me when it is internet related.
 

peritus

Banned
Does sound odd Mike; mines connected via wifi (ethernet bridge and I've never had any issues)

If you still get no progress then I suggest you give D&M tech support (Marantz) a call... on +44 2890 279830; they're really helpful :)
 
D

danmanix

Guest
Hiya Mike,

Did you ever resolve the issue, as the exact same thing is happening to me :)
 

Mike B

Standard Member
Hi Dan,

In the end I had it replaced. Actually I received some excellent service from Marantz's distributor here in Aus and they brought a replacement unit to my house. This unit already had all the upgrades applied. Very happy with it now, sounds great hooked up to some Monitor Audio BX2's.

FWIW They weren't much help on the issue itself though. They did mention that Marantz/Denon in Japan are frustratingly difficult to deal with from a technical perspective...
 

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology
Support AVForums with Patreon

Top Bottom