1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mains hum with Rega Planar 3!!

Discussion in 'Hi-Fi Stereo Systems & Separates' started by morb666, Aug 8, 2005.

  1. morb666

    morb666
    Active Member

    Joined:
    Oct 21, 2004
    Messages:
    312
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    King's Lynn
    Ratings:
    +8
    Hi,

    My Rega deck seems to have developed a humming problem, when the arm is parked then everything is quiet but if you swing the arm over the platter mains hum can be heard increasing in volume towards the center of the platter!!!! Any ideas how to cure this???

    Thanks,
    Morb666
     
  2. Londondecca

    Londondecca
    Active Member

    Joined:
    Dec 21, 2003
    Messages:
    2,080
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Ratings:
    +96
    I would check the earth wire to the amp is nice and secure
     
  3. morb666

    morb666
    Active Member

    Joined:
    Oct 21, 2004
    Messages:
    312
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    King's Lynn
    Ratings:
    +8
    Well, I moved the deck further away from the Amp and problem solved. Odd that it's decided to be a problem now after a couple of years with no problems!! Nevermind at least it's easy to solve with just a bit of judicious seperates placement.

    Cheers,
    Morb666
     

Share This Page

Loading...