1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mains hum with Cambridge Audio Azur 640C

Discussion in 'Hi-Fi Stereo Systems & Separates' started by harmonica98, Dec 30, 2004.

  1. harmonica98

    harmonica98
    Active Member

    Joined:
    Dec 30, 2004
    Messages:
    239
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Ratings:
    +24
    Hi folks

    I've just purchased the above player from Richer Sounds. While I am very happy with the sound, the mains hum does seem very loud compared to other separate CD players I have experienced - is this normal? I didn't have the plug completely in at first which resulted in an extremely loud hum - I have fixed that now but the hum is still very much present. It is not noticeable when playing CDs, but is a little annoying even so.

    Is this just a fact of life with this model, or might I have a duff player?

    Any input gratefully received.

    Thanks

    Tom
     
  2. Ovation

    Ovation
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I'd go back and have it looked at. You're well within the time limit for that.
     
  3. Ed Selley

    Ed Selley
    AVF Reviewer

    Joined:
    Jun 26, 2003
    Messages:
    10,966
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    166
    Ratings:
    +3,338
    The last consignment of transformers seems to have been slightly louder than the earlier ones but a simple circuit breaker (the ones that stop you killing yourself when mowing the lawn) can often help.
     

Share This Page

Loading...