M4A file won't stream on Multicast


Novice Member
Apr 16, 2022
Reaction score
Mooresville, NC
Hello, I'm hoping for some help here.

I have a Yamaha RX-V681 receiver with multicast and I have downloaded the app for my iPhone. I can connect and stream files from my iTunes library, EXCEPT for new Hi-Res files I downloaded from HD Tracks. I tried a sampler file and imported and streamed it without issue.

However, I did need to convert them to M4A using ALAC encoder.

What's weird is that my Hi Res Tears for Fears won't stream. It plays in iTunes on my phone and on the PC just fine. When I select it in multicast, it doesn't do anything.

The file is VBR 3020 KB/s, ALAC codec, 2 channel, 96khz sampling rate, and 24 bit data.

Would anybody have any ideas on how to get this working?


try encoding it in a lower format like 192k AAC with fixed bit rate to see if it plays
Thank you...I'm working on that now but haven't been very successful. I've downloaded a couple of converters but can't seem to change. I'll keep trying.

Thanks again.

I use dBpoweramp with the codec add on's which are available to download free. I can re code just about any audio file to any format.
Thank you for the tip. I found Xmedia Recode before I saw your response and that seems to have worked. I can now stream from the Yamaha MusicCast app to my receiver in hi-res. My files should have worked as they were when they were downloaded but I haven't solved that mystery yet.

I think I'm going to need to find a way to stream them to the receiver another way. They are currently on my HTPC receiver, and some Hi-Res on my phone. I have read some on DAC's but I'm not sure that is the way to go for me.

I have come across certain situations where ALAC would not stream but FLAC does.

The latest video from AVForums

Sony BRAVIA 9 Mini LED TV: The Best HDR TV EVER?
Subscribe to our YouTube channel
Top Bottom