LPCM, DTS-HD, FFDShow & Chapters!

MattMcSpirit

Active Member
Hi all,

I'm so close to getting my x86 7MC nailed down, but I'm encountering a few teething problems with LPCM, True-HD and DTS-HD content.

Basically, I've got my audio configured pretty much exactly as described in Daveybryce's excellent post, combined with Wolvers superb guide, however I'm seeing inconsistencies between different content types.

My HTPC is connected to my Yamaha RX-V2700, which can't take DTS-HD/True-HD natively, but laps up DD, DTS and PCM (usually!). It's connected by HDMI. I'm using the Core i3 530 and a Gigabyte GA-H55M-UD2H. I'm making my MKV's with MakeMKV 1.5.1. I'm using the very latest release of MediaBrowser and I don't yet have any Blu-ray software, like TMT3.

My current FFDShow settings are as follows:

attachment.php


Now, the reason DTS isn't ticked for Pass-through, is because discs like Transformers (ROTF), or Terminator Salvation, won't play when it's ticked. When I tick it, and try and play say, Terminator Salvation, I get the following:

attachment.php


However, with the box still ticked, something like Lord of the Rings, DVD, with DTS soundtrack, plays fine, and the Yamaha Receiver reads DTS on the display.

Unticking the DTS box lets both Lord of the Rings DVD, and any DTS-HD content play, with MPCM appearing on the receiver screen.

When I play something like Terminator Salvation, and look at the FFDShow icons in the bottom right, i see, for audio:

attachment.php


and 2 tracks to choose from:

attachment.php


So, whilst I'm not too bothered about the DTS side of things, have I done something blatantly wrong to cause the DTS tick box to stop DTS-HD movies working? I've always left the DTS-HD box unticked, as I know my Reciever can't do anything with it. Needless to say, if i do actually test with DTS-HD ticked, that fails too, with the same 'cannot play video' message as above.

So, that's DTS, then the fun starts with Dolby Digital and True-HD rips.

Dolby Digital / True-HD

DVD's with a DD 5.1 soundtrack play fine, and lip-sync is spot on, even when i click around the movie timeline with the mouse. It takes a second to sort itself when I click someone random on the timeline, but it returns to normal very quickly, and I'm happy with that. The receiver also displays Dolby Digital.

Then we get onto True-HD content. Take Batman and Robin (I know, but it's just an example!) When I use MakeMKV, I have the following choices for audio:

attachment.php


I choose just the HD audio, as shown in the pic, and go ahead and make the MKV file. Should I be selecting others?

One thing I've noticed with the True-HD movies is when you click on different points in the timeline whilst playing the movie, the lip-sync rapidly falls out of place. This doesn't happen with the Dolby Digital DVDs, nor the DTS/HD content I discussed earlier. In some cases, the audio and video can be seconds apart. It appears to me that the audio is ahead of the video. This has been improved by taking VC1 control off FFDShow and giving it back to Windows, but if anyone has any other suggestions, they would be welcome!

LPCM

I'm having some strange issues with LPCM Audio from Blu-ray's like Casino Royale, and Harry Potter. The movie plays fine, but there's no audio at all. They have PCM audio, yet nothing is coming out. However, if I fire up GraphStudio, and import the MKV, I get the following:

attachment.php


Then, if i manually add a Audio Renderer in the form of the Default DirectSound device:

attachment.php


and play the graph, I get video and sound!!

How do I get this into Media Center?

Chapters

This is an easy one! How do i get chapters working in 7MC? Whenever I click the ->> button, I skips me on 30 seconds with each press. This is on every single rip I've made, so I'm unsure if I'm doing something wrong. MakeMKV correctly identifies the number of chapters, and in the past (on my previous x64 build) I could right click the Haali splitter in the system tray and it would have all the chapters listed, so I'm presuming they're in there somehwhere.

Any advice would be gratefully received!

Matt
 

Attachments

  • Settings.JPG
    Settings.JPG
    76.5 KB · Views: 2,365
  • NoPlayDTS.JPG
    NoPlayDTS.JPG
    19.6 KB · Views: 1,708
  • FFDShowMini.JPG
    FFDShowMini.JPG
    16.6 KB · Views: 1,680
  • FFDShowMini2.JPG
    FFDShowMini2.JPG
    17.9 KB · Views: 1,676
  • BatmanAudio.JPG
    BatmanAudio.JPG
    16.6 KB · Views: 1,655
  • Graph1.JPG
    Graph1.JPG
    19.7 KB · Views: 1,683
  • Graph2.JPG
    Graph2.JPG
    25.5 KB · Views: 1,693

KeithXP

Active Member
This may not be relevant to you, but I have been trying out MakeMKV to rip a few DVD's and Blurays. I have new home built HTPC with Win 7 x64 (just to make the whole codec thing even harder for myself).

I found I could not play any of the MKV's from MakeMKV in 7MC x64. I got exactly the same error as you. I then tried tsMuxer etc as per Wolver's thread and had no problems playing the MKV's at all. Got DTS-MA passthrough as well.

I would definitely try another ripping tool, just in case.
 

MattMcSpirit

Active Member
Hi KeithXP - You may be on to something there - I think I'll have a bash with tsMuxer. I'm not too fussed at this stage as it's still in its early phases, however if I want to roll it out into full Living-Room-Production, I need to get these bits right or the other half will start moaning :)

Still, the Harmony One has softened the blow ;)
 

wolvers

Distinguished Member
Flattery will get you everywhere Matt, so thanks. There's a lot to cover there so I'll try to help with as many points as I can.

Have you tried using libvacodec instead of libdts as your dts decoder? When I was doing some testing with the audio on the BBCHD channel the other day, I found that libvacodec was the most stable out of all the ones I tried. Just an idea really.

Don't expect the timeline bar and skip to work perfectly with mkv playback in 7MC. Meida Controll app is supposed to sort this, as well as chapters, but I have yet to do enough testing to find out for sure. Maybe you could look into it and let the forum know what you find?

LPCM is another area I have yet to dip my toe into and I have noticed a few peeps having problems. I don't actually own any discs with an LPCM track so I will find a list buy one that I would like and do some tesing.

Something i would like to know is what exactly your audio hardware can handle in terms of LPCM. Could it be that either your amp or sound card simply cannot accept LPCM at the bitrate that the track contains? Obviously the PCM version of HD audio tracks that you are sending out are likely to be of a lower bitrate than the LPCM tracks that you are effectively bitstreaming.

Hope I've been of some help.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom