1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Low level hiss with Yam620 and missions?

Discussion in 'AV Receivers & Amplifiers' started by Markster, May 9, 2002.

  1. Markster

    Markster
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Im using the Yamaha DSPAX620 and Mission M series speakers.

    When using the dvd digital connection even with the dvd sound off i can turn the amp up as loud as possible and it is still quiet.
    If i choose any of the other inputs ie for watching sky etc, i get a hissing sound.

    Whilst watching sky the hissing is really starting to annoy me.

    I thought it was the phono cable between the skybox and the player so i changed these but it didnt change so i then removed this cable altogether and turned the volume up without anything plugged in and the hiss is still there.

    Does everyone else have this?
     
  2. mesak

    mesak
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Well, i am having the same thing with my Kenwood 7030 and Tannoys but only if turn-up the volume to -23 DB (usually it is VERY LOUD) - there's weird hiss appears and it doesn't happen with the digital connection (i use optical cable not coax).
    Daniel.
     
  3. Mr.D

    Mr.D
    Well-known Member

    Joined:
    Jul 14, 2000
    Messages:
    11,041
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    133
    Ratings:
    +1,113
    probably the sky box . Probably not really built well enough for your average home cinema fan.
     
  4. Markster

    Markster
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    It is not the sky box as it does the same connected to the tv and as above even when i unplug the sky box altogether i still get a hiss on that channel.
     
  5. WSC

    WSC
    Standard Member

    Joined:
    Nov 1, 2001
    Messages:
    60
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I think that you will find that it is a "feature" of the Yamaha with analogue material. I originally had the Yamaha 420 and it was v. bad with hiss. When I got rid of that I auditioned the Yamaha 620, Denon 1802 and Marantz 5200 the Yamaha was not as bad as the 420 but it still wasn't good. Sorry but I suspect that if you can't take it back you will have to live with it.
     

Share This Page

Loading...