1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Loud Thud!!!

Discussion in 'Subwoofers' started by superfly74, Apr 23, 2004.

  1. superfly74

    superfly74
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have a issue with my AV Connection. Each time I change a DSP from my YAMAHA amp or fwd / rewind / stop my dvd player, a loud thud noise erupts from my Mission subwoofer.

    I know that my equipment is fine but am bewildered as to why this happens. I have an incling that its due to my set-up.

    Basically, I have a s-video / optical connection and the other connections are the subwoofer lead (cambridge) and scart for tv-video.

    Please advise as im going insane in the mem-brain!!!!
     
  2. jmack

    jmack
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i used to get this with a philips 962sa and a aego 5 setup for a while then it just went

    sorry cant be more help
     
  3. wookie

    wookie
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Blown "Muting Transistors"

    Do a search on the forums for the above.
     
  4. superfly74

    superfly74
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    what do mean??
     
  5. wookie

    wookie
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I mean, click on the search tab then search for muting transistors.
    Its quite a common problem with Yamaha's if you even mess about with cables (sub cable) when the amp is turned on.
     
  6. dennis

    dennis
    Active Member

    Joined:
    Jul 2, 2003
    Messages:
    1,239
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    surrey
    Ratings:
    +54
    yup,happened to me.:oops:
     
  7. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    681
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +58
    Never ever touch the sub cables with the power on with the Yamaha amps.... happened to me as well!
     
  8. superfly74

    superfly74
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    :eek: :clap: thanks guys...looks like i might as well upgrade the yamaha then..rather not repair it..anything you can recommend for max price of £300??:rotfl: :smashin:
     
  9. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,906
    the Mordaunt Short MS309 at £229 is reckoned by What Hifi to be the only subwoofer under £250 that they have ever been happy to recommend and they would have still given it 5 stars even if it had cost £300

    Have a look at it here
     
  10. superfly74

    superfly74
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    thanks but i meant a new amp
     
  11. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,906
    That'll teach me to read the whole thread first :oops:
     

Share This Page

Loading...